[package] base-files: fix option parsing of -F/--force parameter
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Aug 2012 18:30:47 +0000 (18:30 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Aug 2012 18:30:47 +0000 (18:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33075 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/sbin/sysupgrade

index 27b5e33..bb88d5d 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=113
+PKG_RELEASE:=114
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 3868dc4..62a4012 100755 (executable)
@@ -25,7 +25,7 @@ while [ -n "$1" ]; do
                -c) export SAVE_OVERLAY=1;;
                -b|--create-backup) export CONF_BACKUP="$2"; shift;;
                -f) export CONF_IMAGE="$2"; shift;;
-               -F|--force) export FORCE=1; shift;;
+               -F|--force) export FORCE=1;;
                -h|--help) export HELP=1; break;;
                -*)
                        echo "Invalid option: $1"