[imagebuilder]
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Sep 2010 22:04:09 +0000 (22:04 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Sep 2010 22:04:09 +0000 (22:04 +0000)
- sync with host opkg changes
- get rid of autogenerated opkg.conf
- utilize dl/ as package cache, useful for remote downloads

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23039 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/imagebuilder/Makefile
target/imagebuilder/files/Makefile
target/imagebuilder/files/opkg-generate-config.sh [deleted file]
target/imagebuilder/files/repositories.conf

index 9e9afb2..1e3519f 100644 (file)
@@ -33,7 +33,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
                $(TMP_DIR)/.targetinfo \
                $(TMP_DIR)/.packageinfo \
                $(PKG_BUILD_DIR)/
-       $(CP) ./files/opkg-generate-config.sh $(PKG_BUILD_DIR)/scripts/
+       $(SED) 's/$$A/$(BOARD)/' $(PKG_BUILD_DIR)/repositories.conf
        $(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
        $(CP) $(STAGING_DIR_HOST)/bin $(PKG_BUILD_DIR)/staging_dir/host/
        $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
index 0590dfa..469c4a2 100644 (file)
@@ -58,10 +58,15 @@ OPKG:= \
   IPKG_CONF_DIR="$(TOPDIR)/tmp" \
   IPKG_OFFLINE_ROOT="$(TARGET_DIR)" \
   $(STAGING_DIR_HOST)/bin/opkg \
-       -f $(TOPDIR)/tmp/opkg.conf \
+       -f $(TOPDIR)/repositories.conf \
        --force-depends \
        --force-overwrite \
-       --force-run-hooks
+       --force-postinstall \
+       --cache $(TOPDIR)/dl \
+       --offline-root $(TARGET_DIR) \
+       --add-dest root:/ \
+       --add-arch all:100 \
+       --add-arch $(ARCH_PACKAGES):200
 
 define Profile
   $(eval $(call Profile/Default))
@@ -83,11 +88,6 @@ _call_info: FORCE
        echo 'Available Profiles:'
        echo; $(PROFILE_LIST)
 
-$(TOPDIR)/tmp/opkg.conf: FORCE
-       @mkdir -p $(TOPDIR)/tmp
-       @mkdir -p $(TARGET_DIR)/tmp
-       @$(TOPDIR)/scripts/opkg-generate-config.sh $(TARGET_DIR)
-
 BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(USER_PACKAGES) $($(USER_PROFILE)_PACKAGES) kernel)
 # "-pkgname" in the package list means remove "pkgname" from the package list
 BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES))
@@ -107,9 +107,10 @@ endif
        $(MAKE) package_postinst
        $(MAKE) build_image
        
-package_index: $(TOPDIR)/tmp/opkg.conf FORCE
+package_index: FORCE
        @echo
        @echo Building package index...
+       @mkdir -p $(TOPDIR)/tmp $(TOPDIR)/dl $(TARGET_DIR)/tmp
        (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
                gzip -9c Packages > Packages.gz \
        ) >/dev/null 2>/dev/null
@@ -145,7 +146,7 @@ build_image: FORCE
        $(NO_TRACE_MAKE) -C target/linux/$(BOARD)/image install TARGET_BUILD=1 IB=1
        
 clean:
-       rm -rf tmp $(TARGET_DIR) $(BIN_DIR)
+       rm -rf $(TOPDIR)/tmp $(TOPDIR)/dl $(TARGET_DIR) $(BIN_DIR)
 
 
 info:
diff --git a/target/imagebuilder/files/opkg-generate-config.sh b/target/imagebuilder/files/opkg-generate-config.sh
deleted file mode 100755 (executable)
index b2047a0..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-
-TOPDIR="$(pwd)"
-TARGETDIR="${1}"
-
-[ -f "$TOPDIR/scripts/${0##*/}" ] || {
-       echo "Please execute within the toplevel directory" >&2
-       exit 1
-}
-
-# Try to find package architecture from packages directory
-PKGARCH=
-for pkg in $TOPDIR/packages/*.ipk; do
-       if [ -f "$pkg" ]; then
-               PKGARCH="${pkg##*/}"
-               PKGARCH="${PKGARCH#*_*_}"
-               PKGARCH="${PKGARCH%.ipk}"
-               [ "$PKGARCH" = all ] || break
-       fi
-done
-
-# Try to find package architecture from the target directory
-[ -n "$PKGARCH" ] || {
-       PKGARCH="${TARGETDIR##*/root-}"
-       [ "$PKGARCH" != "$TARGETDIR" ] || {
-               echo "Cannot determine package architecture" >&2
-               exit 1
-       }
-}
-
-rm -f $TOPDIR/tmp/opkg.conf
-
-[ -f $TOPDIR/repositories.conf ] && \
-       $TOPDIR/staging_dir/host/bin/sed \
-               -n -e "s/\$A/$PKGARCH/g" -e "/^[[:space:]]*src/p" \
-               $TOPDIR/repositories.conf > $TOPDIR/tmp/opkg.conf
-
-cat <<EOT >> $TOPDIR/tmp/opkg.conf
-dest root /
-arch all 100
-arch $PKGARCH 200
-option offline_root $TARGETDIR
-src imagebuilder file:$TOPDIR/packages
-EOT
-
-exit 0
index a8bb183..4a55adb 100644 (file)
@@ -1,5 +1,6 @@
 ## Place your custom repositories here, they must match the architecture and version.
-## The special placeholder "$A" can be used to specify the current package architecture.
-
 # src/gz snapshots http://downloads.openwrt.org/snapshots/trunk/$A/packages
 # src custom file:///usr/src/openwrt/bin/$A/packages
+
+## This is the local package repository, do not remove!
+src imagebuilder file:packages