fix make clean for unconfigured build trees
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 4 Dec 2007 03:04:37 +0000 (03:04 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 4 Dec 2007 03:04:37 +0000 (03:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9655 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
include/toplevel.mk

index e56535e..970b089 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -45,10 +45,10 @@ $(BUILD_DIR)/.prepared: Makefile
 clean: FORCE
        rm -rf $(BUILD_DIR) $(BIN_DIR)
        $(MAKE) target/linux/clean
-       rm -rf $(TMP_DIR)
 
 dirclean: clean
        rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
+       rm -rf $(TMP_DIR)
 
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
index 7930223..040ff51 100644 (file)
@@ -98,7 +98,7 @@ download: .config FORCE
        $(MAKE) -j1 package/download
        $(MAKE) -j1 target/download
 
-clean dirclean:
+clean dirclean: .config
        @$(MAKE) $@ 
 
 prereq:: .config