remove CONFIG_JLEVEL. use make -j in the future
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jul 2007 18:24:47 +0000 (18:24 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jul 2007 18:24:47 +0000 (18:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8237 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
include/kernel-defaults.mk

index 9f92883..2f08b40 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -101,13 +101,6 @@ config TAR_VERBOSITY
        prompt "Tar verbose" if BUILDOPTS
        default n
 
-config JLEVEL
-       int
-       prompt "Number of jobs to run simultaneously" if BUILDOPTS
-       default "1"
-       help
-           Number of jobs to run simultanesouly
-
 config CCACHE
        bool
        prompt "Use ccache" if BUILDOPTS
index 409b7d7..5bbff3e 100644 (file)
@@ -59,7 +59,7 @@ endef
 
 define Kernel/CompileModules/Default
        rm -f $(LINUX_DIR)/vmlinux $(LINUX_DIR)/System.map
-       $(MAKE) -j$(CONFIG_JLEVEL) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" modules
+       $(MAKE) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" modules
 endef
 
 ifeq ($(KERNEL),2.6)
@@ -82,7 +82,7 @@ ifeq ($(KERNEL),2.6)
 endif
 define Kernel/CompileImage/Default
        $(call Kernel/SetInitramfs)
-       $(MAKE) -j$(CONFIG_JLEVEL) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" $(KERNELNAME)
+       $(MAKE) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" $(KERNELNAME)
        $(KERNEL_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
        $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/vmlinux.elf
 endef