b43-tools: get rid of the libfl dependency to fix build errors on mac os x
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Oct 2012 16:39:38 +0000 (16:39 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Oct 2012 16:39:38 +0000 (16:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33934 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/b43-tools/Makefile
tools/b43-tools/patches/002-no_libfl.patch [new file with mode: 0644]

index 391eb25..d58a20e 100644 (file)
@@ -29,6 +29,7 @@ define Host/Compile
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/assembler \
                CFLAGS="$(HOST_CFLAGS) -include endian.h" \
                $(HOST_MAKE_FLAGS) \
+               LDFLAGS= \
                $(1) QUIET_SPARSE=:
 endef
 
diff --git a/tools/b43-tools/patches/002-no_libfl.patch b/tools/b43-tools/patches/002-no_libfl.patch
new file mode 100644 (file)
index 0000000..2e55b08
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/assembler/main.c
++++ b/assembler/main.c
+@@ -1268,6 +1268,11 @@ static void initialize(void)
+ #endif /* YYDEBUG */
+ }
++int yywrap(void)
++{
++      return 1;
++}
++
+ int main(int argc, char **argv)
+ {
+       int err, res = 1;