pcap: fix disabling bluetooth
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 26 Apr 2009 19:35:05 +0000 (19:35 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 26 Apr 2009 19:35:05 +0000 (19:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15428 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libpcap/Makefile

index bc6417d..eef5ff0 100644 (file)
@@ -40,6 +40,7 @@ define Package/libpcap/config
                bool "Include bluetooth support"
                depends PACKAGE_libpcap
                depends PACKAGE_kmod-bluetooth
+               depends BROKEN
                default n
 
 endef
@@ -62,6 +63,7 @@ define Build/Compile
        $(if $(CONFIG_PCAP_HAS_USB),,$(SED) '/^#define PCAP_SUPPORT_USB/D' $(PKG_BUILD_DIR)/config.h)
        $(if $(CONFIG_PCAP_HAS_USB),,$(SED) 's/pcap-usb-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
        $(if $(CONFIG_PCAP_HAS_BT),,$(SED) '/^#define PCAP_SUPPORT_BT/D' $(PKG_BUILD_DIR)/config.h)
+       $(if $(CONFIG_PCAP_HAS_BT),,$(SED) 's/pcap-bt-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include" \
                DESTDIR="$(PKG_INSTALL_DIR)" \