[omap35xx] gumstix: create ubifs images
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Feb 2011 08:16:35 +0000 (08:16 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Feb 2011 08:16:35 +0000 (08:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25356 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/omap35xx/gumstix/profiles/gumstix.mk
target/linux/omap35xx/image/Makefile

index 698eb45..0b82ec1 100644 (file)
@@ -11,7 +11,7 @@ define Profile/Gumstix
   NAME:=gumstix
   PACKAGES:=-iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
                -firewall -mtd -hotplug2 -udevtrigger -dropbear \
-               ext4 usb udev kmod-bluetooth ntpclient wpa-supplicant \
+               ext4 ubifs usb udev kmod-bluetooth ntpclient wpa-supplicant \
                wireless-tools wpa-cli \
                bluez-utils bluez-hcidump usbutils \
                kmod-usb-serial kmod-usb-serial-cp210x kmod-usb-serial-ftdi \
index e238c48..aed7b30 100644 (file)
@@ -23,13 +23,11 @@ define Image/BuildKernel
        rm linux.bin
 endef
 
-ifndef CONFIG_TARGET_omap35xx_gumstix
 define Image/Build
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-root.$(1)
-       PADDING="true" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).image 4 $(KDIR)/root.bootscript 240 $(KDIR)/root.$(1)
+#      PADDING="true" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).image 4 $(KDIR)/root.bootscript 240 $(KDIR)/root.$(1)
        $(call Image/Build/$(1),$(1))
 endef
-endif
 
 ifdef CONFIG_TARGET_omap35xx_gumstix
 define Image/Prepare