rb532: really fix squashfs images
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Jul 2014 08:51:55 +0000 (08:51 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Jul 2014 08:51:55 +0000 (08:51 +0000)
The previous attempt (r40717) to fix squashfx made the system bootable but
overlayfs remained broken.
This enables block2mtd again using the right partition number and naming
and adds MTD_ROOTFS_SPLIT option.
However onboard rootfs partition name had to be renamed to place overlay on
CF instead of onboard NAND.

Signed-off-by: Roman Yeryomin <roman@advem.lv>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41541 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/rb532/config-3.10
target/linux/rb532/image/Makefile
target/linux/rb532/patches-3.10/004-rb532_partition_info-rename-rootfs-to-rootfs_onboard.patch [new file with mode: 0644]

index 3e7c9e4..5e7dd3d 100644 (file)
@@ -103,7 +103,7 @@ CONFIG_MTD_NAND_ECC=y
 CONFIG_MTD_NAND_PLATFORM=y
 CONFIG_MTD_PHYSMAP=y
 # CONFIG_MTD_ROOTFS_ROOT_DEV is not set
-# CONFIG_MTD_ROOTFS_SPLIT is not set
+CONFIG_MTD_ROOTFS_SPLIT=y
 # CONFIG_MTD_SM_COMMON is not set
 # CONFIG_MTD_SPLIT is not set
 CONFIG_NEED_DMA_MAP_STATE=y
index 65ef919..e33fbab 100644 (file)
@@ -56,7 +56,7 @@ root=/dev/sda2 rootfstype=ext4
 endef
 
 define Image/cmdline/squashfs
-root=/dev/sda2 rootfstype=squashfs
+block2mtd.block2mtd=/dev/sda2,65536,rootfs root=/dev/mtdblock2 rootfstype=squashfs
 endef
 
 define Image/cmdline/yaffs2
diff --git a/target/linux/rb532/patches-3.10/004-rb532_partition_info-rename-rootfs-to-rootfs_onboard.patch b/target/linux/rb532/patches-3.10/004-rb532_partition_info-rename-rootfs-to-rootfs_onboard.patch
new file mode 100644 (file)
index 0000000..e3f6c41
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/mips/rb532/devices.c        2014-07-07 01:05:10.000000000 +0300
++++ b/arch/mips/rb532/devices.c        2014-07-07 01:05:27.268505016 +0300
+@@ -202,7 +202,7 @@ static struct mtd_partition rb532_partit
+               .offset = 0,
+               .size = 4 * 1024 * 1024,
+       }, {
+-              .name = "rootfs",
++              .name = "rootfs_onboard",
+               .offset = MTDPART_OFS_NXTBLK,
+               .size = MTDPART_SIZ_FULL,
+       }