build: for cmake, always use ccache from staging dir instead of relying on the host
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Jan 2016 14:44:30 +0000 (14:44 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Jan 2016 14:44:30 +0000 (14:44 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48079 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/cmake.mk

index 4207a4d..4e4169a 100644 (file)
@@ -18,10 +18,7 @@ ifeq ($(CONFIG_CCACHE),)
  CMAKE_C_COMPILER_ARG1:=
  CMAKE_CXX_COMPILER_ARG1:=
 else
-  CCACHE:=$(shell which ccache)
-  ifeq ($(CCACHE),)
-    CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
-  endif
+  CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
   CMAKE_C_COMPILER:=$(CCACHE)
   CMAKE_C_COMPILER_ARG1:=$(TARGET_CC_NOCACHE)
   CMAKE_CXX_COMPILER:=$(CCACHE)