hostapd: fix build errors on supplicant-only builds
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Mar 2013 16:11:32 +0000 (16:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Mar 2013 16:11:32 +0000 (16:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36085 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/hostapd/Makefile
package/network/services/hostapd/patches/700-ubus_support.patch

index 0c44a8b..7024844 100644 (file)
@@ -225,7 +225,9 @@ TARGET_CPPFLAGS := \
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
-TARGET_LDFLAGS += -lubox -lubus
+ifeq ($(findstring supplicant,$(BUILD_VARIANT)),)
+  TARGET_LDFLAGS += -lubox -lubus
+endif
 
 ifdef CONFIG_PACKAGE_kmod-mac80211
   TARGET_LDFLAGS += -lm -lnl-tiny
index 92ca7b2..ad1a45b 100644 (file)
 +      const u8 *addr;
 +};
 +
++struct hostapd_iface;
++struct hostapd_data;
++
 +#ifdef UBUS_SUPPORT
 +
 +#include <libubox/avl.h>
 +#include <libubus.h>
 +
-+struct hostapd_iface;
-+struct hostapd_data;
-+
 +struct hostapd_ubus_iface {
 +      struct ubus_object obj;
 +};