[package] gdb: gdbserver package dependency fix (#11179)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 Sep 2012 15:13:50 +0000 (15:13 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 Sep 2012 15:13:50 +0000 (15:13 +0000)
In the current trunk, gdbserver is not building anymore (with EGLIBC 2.15
selected) due to a missing dependency:
Package gdbserver is missing dependencies for the following libraries:
libthread_db.so.1

In order to fix it, the system shared lib libthread_db.so.1 is copied from
the toolchain lib dir into the gdb package target structure (/usr/lib) to
pass the dependency checks.
This patch was (quickly) reviewed by Paul Fertser on IRC.

Signed-off-by: xxiao <xxiao@fosiao.com>
Signed-off-by: Matthieu Boujonnier <openwrt-devel@metaverse.fr>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33479 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/gdb/Makefile

index 879ba3d..cf0b9ea 100644 (file)
@@ -77,6 +77,10 @@ endef
 define Package/gdbserver/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
 define Package/gdbserver/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
+ifneq ($(CONFIG_USE_EGLIBC),)
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(TOOLCHAIN_DIR)/lib/libthread_db* $(1)/usr/lib
+endif
 endef
 
 $(eval $(call BuildPackage,gdb))
 endef
 
 $(eval $(call BuildPackage,gdb))