iwinfo: adjust for changed wpa_supplicant control socket path
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 10 May 2014 15:31:49 +0000 (15:31 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 10 May 2014 15:31:49 +0000 (15:31 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40747 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iwinfo/Makefile
package/network/utils/iwinfo/src/iwinfo_nl80211.c

index 9bebb7a..699682b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2013 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2010-2014 Jo-Philipp Wich <xm@subsignal.org>
 #
 # This is free software, licensed under the GPL 2 license.
 #
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=47
+PKG_RELEASE:=48
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index a258d2f..854be6b 100644 (file)
@@ -526,7 +526,13 @@ static char * nl80211_wpactl_info(const char *ifname, const char *cmd,
                goto out;
 
        if (connect(sock, (struct sockaddr *) &remote, remote_length))
-               goto out;
+       {
+               remote_length = sizeof(remote.sun_family) + sprintf(remote.sun_path,
+                       "/var/run/wpa_supplicant/%s", ifname);
+
+               if (connect(sock, (struct sockaddr *) &remote, remote_length))
+                       goto out;
+       }
 
        local.sun_family = AF_UNIX;
        local_length = sizeof(local.sun_family) +