ramips: add support for Planex MZK-DP150N
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 Jul 2015 12:51:08 +0000 (12:51 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 Jul 2015 12:51:08 +0000 (12:51 +0000)
This patch add support for Planex MZK-DP150N.
a mini router on the MT7620A SoC with one Ethernet port and a 802.11n 2.4 GHz radio.

Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46405 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/MZK-DP150N.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/planex.mk [new file with mode: 0644]

index fe3a79d..0672a22 100755 (executable)
@@ -265,6 +265,9 @@ case $board in
        zte-q7)
                set_wifi_led "zte:blue:status"
                ;;
+       mzk-dp150n)
+               ucidef_set_led_default "power" "power" "mzkdp150n:green:power" "1"
+               ;;
 esac
 
 board_config_flush
index 9fb3535..f896afa 100755 (executable)
@@ -261,6 +261,13 @@ ramips_setup_interfaces()
                ucidef_add_switch_vlan "switch0" "1" "1 2 3 4 5t"
                ucidef_add_switch_vlan "switch0" "2" "0 5t"
                ;;
+
+       mzk-dp150n)
+               ucidef_set_interface_lan "eth0.1"
+               ucidef_add_switch "switch0" "1" "1"
+               ucidef_add_switch_vlan "switch0" "1" "0 4 6t"
+               ;;
+
        *)
                RT3X5X=`cat /proc/cpuinfo | egrep "(RT3.5|RT5350)"`
                if [ -n "${RT3X5X}" ]; then
index 46e519a..319763e 100644 (file)
@@ -249,6 +249,9 @@ get_status_led() {
        zte-q7)
                status_led="zte:red:status"
                ;;
+       mzk-dp150n)
+               status_led="mzkdp150n:green:power"
+               ;;
        esac
 }
 
index 3d40ab9..d7fd5f9 100755 (executable)
@@ -421,6 +421,9 @@ ramips_board_detect() {
        *"Mediatek MT7628AN evaluation board")
                name="mt7628"
                ;;
+       *"Planex MZK-DP150N")
+               name="mzk-dp150n"
+               ;;
        *)
                name="generic"
                ;;
index 8f45a84..04af322 100755 (executable)
@@ -71,6 +71,7 @@ platform_check_image() {
        mpr-a2 | \
        mr-102n | \
        mzk-w300nh2 | \
+       mzk-dp150n | \
        nbg-419n | \
        nw718 | \
        omni-emb | \
diff --git a/target/linux/ramips/dts/MZK-DP150N.dts b/target/linux/ramips/dts/MZK-DP150N.dts
new file mode 100644 (file)
index 0000000..ae986f7
--- /dev/null
@@ -0,0 +1,98 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "MZK-DP150N", "ralink,rt5350-soc";
+       model = "Planex MZK-DP150N";
+
+       palmbus@10000000 {
+               gpio1: gpio@660 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "s25fl064k";
+                               reg = <0>;
+                               linux,modalias = "m25p80", "s25fl064k";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "uboot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "uboot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x3b0000>;
+                               };
+                       };
+
+                       spidev@1 {
+                               compatible = "linux,spidev";
+                               spi-max-frequency = <10000000>;
+                               reg = <1>;
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "jtag", "uartf", "led";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x17>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+               ralink,led-polarity = <1>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               power {
+                       label = "mzkdp150n:green:power";
+                       gpios = <&gpio0 9 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
index 2fe5fdd..b71d935 100644 (file)
@@ -609,6 +609,8 @@ Image/Build/Profile/W502U=$(call BuildFirmware/Default8M/$(1),$(1),w502u,W502U)
 Image/Build/Profile/WCR150GN=$(call BuildFirmware/Default4M/$(1),$(1),wcr150gn,WCR150GN)
 
 
+Image/Build/Profile/MZK-DP150N=$(call BuildFirmware/Default4M/$(1),$(1),mzk-dp150n,MZK-DP150N)
+
 buffalo_whrg300n_mtd_size=3801088
 define BuildFirmware/WHRG300N/squashfs
        $(call BuildFirmware/Default4M/$(1),$(1),whr-g300n,WHR-G300N)
@@ -772,6 +774,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/X5,$(1))
        $(call Image/Build/Profile/X8,$(1))
        $(call Image/Build/Profile/XDXRN502J,$(1))
+       $(call Image/Build/Profile/MZK-DP150N,$(1))
 
 endef
 endif
diff --git a/target/linux/ramips/rt305x/profiles/planex.mk b/target/linux/ramips/rt305x/profiles/planex.mk
new file mode 100644 (file)
index 0000000..d0d9ac9
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MZK-DP150N
+       NAME:=Planex MZK-DP150N
+       PACKAGES:= kmod-spi-dev
+endef
+
+define Profile/MZK-DP150N/Description
+       Package set optimized for the Planex MZK-DP150N.
+endef
+
+$(eval $(call Profile,MZK-DP150N))