kernel: fix module packages postinst by pointing to the new functions.sh location
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 20 Dec 2012 15:29:37 +0000 (15:29 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 20 Dec 2012 15:29:37 +0000 (15:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34804 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index 6185237..8df70ba 100644 (file)
@@ -104,7 +104,7 @@ define ModuleAutoLoad
                mkdir -p $(2)/CONTROL; \
                echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
                echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
-               echo ". /etc/functions.sh" >> $(2)/CONTROL/postinst; \
+               echo ". /lib/functions.sh" >> $(2)/CONTROL/postinst; \
                echo "load_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
                chmod 0755 $(2)/CONTROL/postinst; \
        fi