rules.mk: add _dsp to ARCH_SUFFIX if the dsp ase is used
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 May 2013 16:45:51 +0000 (16:45 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 May 2013 16:45:51 +0000 (16:45 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36566 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk

index 2333f2a..b951005 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -63,6 +63,12 @@ endif
 ifneq ($(filter -mips%r2,$(TARGET_OPTIMIZATION)),)
   ARCH_SUFFIX:=_r2
 endif
+ifneq ($(filter -mdsp,$(TARGET_OPTIMIZATION)),)
+  ARCH_SUFFIX:=$(ARCH_SUFFIX)_dsp
+endif
+ifneq ($(filter -mdspr2,$(TARGET_OPTIMIZATION)),)
+  ARCH_SUFFIX:=$(ARCH_SUFFIX)_dspr2
+endif
 ifdef CONFIG_USE_MIPS16
    TARGET_OPTIMIZATION+= -minterlink-mips16 -mips16
 endif