[ar7] create AC49x subtarget
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Nov 2012 16:11:34 +0000 (16:11 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Nov 2012 16:11:34 +0000 (16:11 +0000)
Signed-off-by: Daniel Golle <dgolle@allnet.de>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34148 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar7/ac49x/config-default [new file with mode: 0644]
target/linux/ar7/ac49x/profiles/210-None.mk [new file with mode: 0644]
target/linux/ar7/ac49x/target.mk [new file with mode: 0644]

diff --git a/target/linux/ar7/ac49x/config-default b/target/linux/ar7/ac49x/config-default
new file mode 100644 (file)
index 0000000..6c7e5fa
--- /dev/null
@@ -0,0 +1,6 @@
+CONFIG_AR7_AC49X=y
+# CONFIG_AR7_TI is not set
+CONFIG_AR7_TYPE_AC49X=y
+# CONFIG_AR7_TYPE_TI is not set
+CONFIG_MTD_AC49X_PARTS=y
+# CONFIG_MTD_AR7_PARTS is not set
diff --git a/target/linux/ar7/ac49x/profiles/210-None.mk b/target/linux/ar7/ac49x/profiles/210-None.mk
new file mode 100644 (file)
index 0000000..2fcfacd
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+  NAME:=No WiFi
+  PACKAGES:=
+endef
+
+define Profile/None/Description
+       Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+
diff --git a/target/linux/ar7/ac49x/target.mk b/target/linux/ar7/ac49x/target.mk
new file mode 100644 (file)
index 0000000..47f3ab2
--- /dev/null
@@ -0,0 +1,10 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+
+SUBTARGET:=ac49x
+BOARDNAME:=AudioCodes AC49x
+
+define Target/Description
+       Build firmware images for AudioCodes AC49x based routers.
+endef