kernel: update to kernel 3.14.3
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 8 May 2014 21:53:27 +0000 (21:53 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 8 May 2014 21:53:27 +0000 (21:53 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40736 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/generic/patches-3.14/100-overlayfs.patch
target/linux/generic/patches-3.14/204-module_strip.patch
target/linux/x86_64/Makefile

index 44a7f11..50fcfcb 100644 (file)
@@ -26,8 +26,8 @@ endif
 ifeq ($(LINUX_VERSION),3.13.7)
   LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
 endif
-ifeq ($(LINUX_VERSION),3.14)
-  LINUX_KERNEL_MD5SUM:=b621207b3f6ecbb67db18b13258f8ea8
+ifeq ($(LINUX_VERSION),3.14.3)
+  LINUX_KERNEL_MD5SUM:=99043433ad7368d2471b4743c9f562a2
 endif
 
 # disable the md5sum check for unknown kernel versions
index 9007c96..218b5c8 100644 (file)
  file_ra_state_init(struct file_ra_state *ra, struct address_space *mapping);
 --- a/include/linux/mount.h
 +++ b/include/linux/mount.h
-@@ -71,6 +71,9 @@ extern void mnt_pin(struct vfsmount *mnt
+@@ -74,6 +74,9 @@ extern void mnt_pin(struct vfsmount *mnt
  extern void mnt_unpin(struct vfsmount *mnt);
  extern int __mnt_is_readonly(struct vfsmount *mnt);
  
index 6d9aabf..6790ac0 100644 (file)
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1823,6 +1823,13 @@ config MODULE_SIG_HASH
+@@ -1830,6 +1830,13 @@ config MODULE_SIG_HASH
        default "sha384" if MODULE_SIG_SHA384
        default "sha512" if MODULE_SIG_SHA512
  
index 085ba68..43326b2 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86_64
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.14
+LINUX_VERSION:=3.14.3
 
 KERNELNAME:=bzImage