kernel: fix the pcspkr module, add proper dependencies, add the actual sound module
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Oct 2012 15:11:35 +0000 (15:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Oct 2012 15:11:35 +0000 (15:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33921 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/sound.mk

index 4ccdc8b..3d12ba6 100644 (file)
@@ -7,21 +7,6 @@
 
 SOUND_MENU:=Sound Support
 
-define KernelPackage/pcspkr
-  SUBMENU:=$(SOUND_MENU)
-  TITLE:=PC speaker support
-  KCONFIG:=CONFIG_INPUT_PCSPKR
-  FILES:=$(LINUX_DIR)/drivers/input/misc/pcspkr.ko
-  AUTOLOAD:=$(call AutoLoad,50,pcspkr)
-endef
-
-define KernelPackage/pcspkr/description
- This enables sounds (tones) through the pc speaker
-endef
-
-$(eval $(call KernelPackage,pcspkr))
-
-
 # allow targets to override the soundcore stuff
 SOUNDCORE_LOAD ?= \
        soundcore \
@@ -201,3 +186,24 @@ define KernelPackage/sound-soc-gw_avila
 endef
 
 $(eval $(call KernelPackage,sound-soc-gw_avila))
+
+
+define KernelPackage/pcspkr
+  DEPENDS:=@!TARGET_x86
+  TITLE:=PC speaker support
+  KCONFIG:= \
+       CONFIG_INPUT_PCSPKR \
+       CONFIG_SND_PCSP
+  FILES:= \
+       $(LINUX_DIR)/drivers/input/misc/pcspkr.ko \
+       $(LINUX_DIR)/sound/drivers/pcsp/snd-pcsp.ko
+  AUTOLOAD:=$(call AutoLoad,50,pcspkr snd-pcsp)
+  $(call AddDepends/input)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/pcspkr/description
+ This enables sounds (tones) through the pc speaker
+endef
+
+$(eval $(call KernelPackage,pcspkr))