enable preinit in a few other platforms
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 Mar 2007 22:36:45 +0000 (22:36 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 Mar 2007 22:36:45 +0000 (22:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6482 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/aruba-2.6/patches/000-aruba.patch
target/linux/au1000-2.6/config/default
target/linux/ixp4xx-2.6/config/default
target/linux/rb532-2.6/base-files/default/sbin/cf2nand
target/linux/rb532-2.6/image/Makefile

index 07e1470..9954a49 100644 (file)
@@ -630,10 +630,10 @@ diff -Nur linux-2.6.17/arch/mips/aruba/prom.c linux-2.6.17-owrt/arch/mips/aruba/
 +
 +/* Kernel Boot parameters */
 +static unsigned char bootparm[] = 
++      "init=/etc/preinit "
 +      "mtdparts=physmap-flash.0:3520k@0x080000(zImage),2752k@0x140000(JFFS2),8k@0x3f8000(NVRAM) "
 +      "console=ttyS0,9600 root=/dev/mtdblock1 rootfstype=jffs2 ";
 +
-+
 +extern unsigned long mips_machgroup;
 +extern unsigned long mips_machtype;
 +
index 351d6fd..967703a 100644 (file)
@@ -7,7 +7,7 @@ CONFIG_64BIT_PHYS_ADDR=y
 CONFIG_BASE_SMALL=0
 # CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
 CONFIG_CHR_DEV_SG=m
-CONFIG_CMDLINE="root=/dev/mtdblock0 rootfstype=jffs2"
+CONFIG_CMDLINE="root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit"
 # CONFIG_CPU_BIG_ENDIAN is not set
 CONFIG_CPU_HAS_LLSC=y
 CONFIG_CPU_HAS_PREFETCH=y
index 7c9fec0..0acfdf4 100644 (file)
@@ -57,7 +57,7 @@ CONFIG_BASE_SMALL=0
 # CONFIG_BSD_DISKLABEL is not set
 # CONFIG_BT is not set
 # CONFIG_CIFS_STATS is not set
-CONFIG_CMDLINE="root=/dev/mtdblock2 rootfstype=jffs2 noinitrd console=ttyS0,115200"
+CONFIG_CMDLINE="root=/dev/mtdblock2 rootfstype=jffs2 noinitrd console=ttyS0,115200 init=/etc/preinit"
 # CONFIG_CONFIGFS_FS is not set
 CONFIG_CPU_32=y
 CONFIG_CPU_32v5=y
index 9cb216c..74ac894 100755 (executable)
@@ -45,7 +45,7 @@ mount -t yaffs2 "$boot" /tmp/cf2nand/p1
 mount -t yaffs2 "$main" /tmp/cf2nand/p2
 
 echo "Copying kernel..."
-copy_kernel /dev/cf/card0/part1 /tmp/cf2nand/p1/kernel "root=/dev/mtdblock1 rootfstype=yaffs2 " 2>/dev/null >/dev/null
+copy_kernel /dev/cf/card0/part1 /tmp/cf2nand/p1/kernel "root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit " 2>/dev/null >/dev/null
 umount /tmp/cf2nand/p1
 rmdir /tmp/cf2nand/p1
 
index e6794c0..149a7e2 100644 (file)
@@ -38,15 +38,15 @@ define Image/BuildKernel
 endef
 
 define Image/cmdline/jffs2-64k
-block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=jffs2
+block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
 endef
 
 define Image/cmdline/jffs2-128k
-block2mtd.block2mtd=/dev/cfa2,131072 root=/dev/mtdblock0 rootfstype=jffs2
+block2mtd.block2mtd=/dev/cfa2,131072 root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
 endef
 
 define Image/cmdline/ext2
-root=/dev/cfa2 rootfstype=ext2
+root=/dev/cfa2 rootfstype=ext2 init=/etc/preinit
 endef
 
 define Image/Build