add autoconf (fixes opkg build issues)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 27 Aug 2008 20:18:53 +0000 (20:18 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 27 Aug 2008 20:18:53 +0000 (20:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12410 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/autoconf/Makefile [new file with mode: 0644]

index 816cd98..3cfbb8b 100644 (file)
@@ -9,7 +9,7 @@
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
new file mode 100644 (file)
index 0000000..cf66563
--- /dev/null
@@ -0,0 +1,38 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=autoconf
+PKG_VERSION:=2.62
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/autoconf
+PKG_MD5SUM:=e1fb8fe0b22e651240afdfa2be537a3c
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+       $(call Build/Configure/Default,\
+               --datarootdir=$(STAGING_DIR_HOST)/share \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+       $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+       $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))