the attached patch adds the -a option to the feeds install command.
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 25 Jan 2008 11:33:20 +0000 (11:33 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 25 Jan 2008 11:33:20 +0000 (11:33 +0000)
Therefore following command option should work now

./scripts/feeds install -a
./scripts/feeds install -a -p xwrt

To-do:
- The next step should be to replace the current make package/symlinks implementation with ./scripts/feeds install -a .
  ( the locations of the packages within ./packages are different with both methods )
- The current feed script is not able to handle "Provides" statements properly. The dependencies will be installed only if they are real package names and not aliases (provides) .

Note:
This patch also includes the previous patch reg. directory (ClearCase) support from 30.12.07.

br/R

Signed-off-by: ralph <ralph.hempel@infineon.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10252 3c298f89-4303-0410-b956-a3cf2f4a3e73

scripts/feeds

index f22adc5..6fda84e 100755 (executable)
@@ -6,6 +6,7 @@ use lib "$FindBin::Bin";
 use metadata;
 use warnings;
 use strict;
+use Cwd 'abs_path';
 
 chdir "$FindBin::Bin/..";
 $ENV{TOPDIR}=getcwd();
@@ -55,6 +56,36 @@ sub update_svn($$) {
        return 0;
 }
 
+sub update_cpy($$) {
+       my $name = shift;
+       my $src = shift;
+
+       system("cp -Rf $src ./feeds/$name");
+       -d "./feeds/$name.tmp" or mkdir "./feeds/$name.tmp" or return 1;
+       -d "./feeds/$name.tmp/info" or mkdir "./feeds/$name.tmp/info" or return 1;
+
+       system("make -s prepare-mk TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
+       system("make -s -f include/scan.mk IS_TTY=1 SCAN_TARGET=\"packageinfo\" SCAN_DIR=\"feeds/$name\" SCAN_NAME=\"package\" SCAN_DEPS=\"$ENV{TOPDIR}/include/package*.mk\" SCAN_DEPTH=4 SCAN_EXTRA=\"\" TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
+       system("ln -sf $name.tmp/.packageinfo ./feeds/$name.index");
+
+       return 0;
+}
+
+sub update_link($$) {
+       my $name = shift;
+       my $src = abs_path(shift);
+
+       system("ln -sf $src ./feeds/$name");
+       -d "./feeds/$name.tmp" or mkdir "./feeds/$name.tmp" or return 1;
+       -d "./feeds/$name.tmp/info" or mkdir "./feeds/$name.tmp/info" or return 1;
+
+       system("make -s prepare-mk TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
+       system("make -s -f include/scan.mk IS_TTY=1 SCAN_TARGET=\"packageinfo\" SCAN_DIR=\"feeds/$name\" SCAN_NAME=\"package\" SCAN_DEPS=\"$ENV{TOPDIR}/include/package*.mk\" SCAN_DEPTH=4 SCAN_EXTRA=\"\" TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
+       system("ln -sf $name.tmp/.packageinfo ./feeds/$name.index");
+
+       return 0;
+}
+
 sub get_feed($) {
        my $feed = shift;
 
@@ -74,7 +105,7 @@ sub search_feed {
        my $feed = shift;
        my @substr = @_;
        my $display;
-       
+
        return unless @substr > 0;
        get_feed($feed);
        foreach my $name (sort { lc($a) cmp lc($b) } keys %package) {
@@ -110,21 +141,30 @@ sub search {
        }
 }
 
-sub install_svn() {
+sub install_generic() {
        my $feed = shift;
        my $pkg = shift;
        my $path = $pkg->{makefile};
-       $path =~ s/\/Makefile$//;
+       
+       if($path) {
+       
+               $path =~ s/\/Makefile$//;
 
-       -d "./package/feeds" or mkdir "./package/feeds";
-       -d "./package/feeds/$feed->[1]" or mkdir "./package/feeds/$feed->[1]";
-       system("ln -sf ../../../$path ./package/feeds/$feed->[1]/");
+               -d "./package/feeds" or mkdir "./package/feeds";
+               -d "./package/feeds/$feed->[1]" or mkdir "./package/feeds/$feed->[1]";
+               system("ln -sf ../../../$path ./package/feeds/$feed->[1]/");
 
+       } else {
+               warn "Package is not valid\n";
+               return 1;
+       }
        return 0;
 }
 
 my %install_method = (
-       'src-svn' => \&install_svn
+       'src-svn' => \&install_generic,
+       'src-cpy' => \&install_generic,
+       'src-link' => \&install_generic
 );
 
 my %feed;
@@ -149,11 +189,16 @@ sub install_package {
        $feed = lookup_package($feed, $name);
        $feed or do {
                $installed{$name} and return 0;
-               warn "WARNING: Package '$name' is not available.\n";
+               warn "WARNING: No feed for package '$name' found.\n";
                return 1;
        };
 
        my $pkg = $feed{$feed->[1]}->{$name} or return 1;
+       $pkg->{name} or do {
+               $installed{$name} and return 0;
+               warn "WARNING: Package '$name' is not available in feed $feed->[1].\n";
+               return 1;
+       };
        my $src = $pkg->{src};
        my $type = $feed->[0];
        $src or $src = $name;
@@ -194,7 +239,7 @@ sub refresh_config {
        # workaround for timestamp check
        system("rm -f tmp/.packageinfo");
 
-       # refresh the config 
+       # refresh the config
        system("make oldconfig CONFDEFAULT=\"$default\" Config.in >/dev/null 2>/dev/null");
 }
 
@@ -203,8 +248,8 @@ sub install {
        my %opts;
        my $feed;
        my $ret = 0;
-       
-       getopt('p:d:', \%opts);
+
+       getopts('ap:d:', \%opts);
        get_installed();
 
        foreach my $f (@feeds) {
@@ -215,12 +260,29 @@ sub install {
                $opts{p} and $f->[1] eq $opts{p} and $feed = $f;
        }
 
-       while ($name = shift @ARGV) {
-               install_package($feed, $name) == 0 or $ret = 1;
+       if($opts{a}) {
+               foreach my $f (@feeds) {
+                       if (!defined($opts{p}) or $opts{p} eq $f->[1]) {
+                               printf "Installing all packages from feed %s.\n", $f->[1];
+                               get_feed($f->[1]);
+                               foreach my $name (sort { lc($a) cmp lc($b) } keys %package) {
+                                       my $p = $package{$name};
+                                       if( $p->{name} ) {
+                                               install_package($feed, $p->{name}) == 0 or $ret = 1;
+                                       } else {
+                                               warn "WARNING: Package '$name' is not available\n";
+                                       }
+                               }
+                       }
+               }
+       } else {
+               while ($name = shift @ARGV) {
+                       install_package($feed, $name) == 0 or $ret = 1;
+               }
        }
 
        # workaround for timestamp check
-       
+
        # set the defaults
        if ($opts{d} and $opts{d} =~ /^[ymn]$/) {
                refresh_config($opts{d});
@@ -261,6 +323,7 @@ Usage: $0 <command> [options]
 Commands:
        install [options] <package>: Install a package
        Options:
+           -a installs all packages from all feeds or from the specified feed
            -p <feedname>: Prefer this feed when installing packages
            -d <y|m|n>:    Set default for newly installed packages
 
@@ -279,7 +342,9 @@ EOF
 }
 
 my %update_method = (
-       'src-svn' => \&update_svn
+       'src-svn' => \&update_svn,
+       'src-cpy' => \&update_cpy,
+       'src-link' => \&update_link
 );
 
 my %commands = (