This adds Gateworks Laguna family board support. Note that some Laguna
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Apr 2013 16:04:31 +0000 (16:04 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Apr 2013 16:04:31 +0000 (16:04 +0000)
boards have SPI flash and others have NOR flash, thus the size/erasesize
are detected dynamically.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36313 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/cns3xxx [new file with mode: 0644]

index 55aaf88..ded9678 100644 (file)
@@ -69,6 +69,10 @@ ifneq ($(CONFIG_TARGET_ramips),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_BIN) ./files/ramips $(1)/etc/uci-defaults/uboot-envtools
 endif
+ifneq ($(CONFIG_TARGET_cns3xxx),)
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_BIN) ./files/cns3xxx $(1)/etc/uci-defaults/uboot-envtools
+endif
 endef
 
 $(eval $(call BuildPackage,uboot-envtools))
diff --git a/package/boot/uboot-envtools/files/cns3xxx b/package/boot/uboot-envtools/files/cns3xxx
new file mode 100644 (file)
index 0000000..a56be15
--- /dev/null
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+
+[ -e /etc/config/ubootenv ] && exit 0
+
+touch /etc/config/ubootenv
+
+. /lib/cns3xxx.sh
+. /lib/uboot-envtools.sh
+. /lib/functions.sh
+
+board=$(cns3xxx_board_name)
+
+case "$board" in
+laguna)
+       # Laguna uboot env size/erasesize vary depending on NOR vs SPI FLASH
+       size=$(grep mtd1 /proc/mtd | awk '{print $2}')
+       erasesize=$(grep mtd1 /proc/mtd | awk '{print $3}')
+       ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x$size" "0x$erasesize"
+       ;;
+esac
+
+config_load ubootenv
+config_foreach ubootenv_add_app_config ubootenv
+
+exit 0