kernel: add a new global config symbol for enabling rfkill support (can be enabled...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Jul 2013 11:55:30 +0000 (11:55 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Jul 2013 11:55:30 +0000 (11:55 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37491 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
package/kernel/linux/modules/001-depends.mk
package/kernel/linux/modules/other.mk
scripts/metadata.pl
target/Config.in

index 11f14d6..db3094d 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -325,6 +325,10 @@ menu "Global build settings"
        config KERNEL_KEXEC
                bool "Enable kexec support"
 
+       config USE_RFKILL
+               bool "Enable rfkill support"
+               default RFKILL_SUPPORT
+
        #
        # CGROUP support symbols
        #
index ed89431..d0ad083 100644 (file)
@@ -22,13 +22,8 @@ define AddDepends/nls
   DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
 endef
 
-
-define SetDepends/rfkill
-  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx) $(1)
-endef
-
 define AddDepends/rfkill
-  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_cns3xxx||TARGET_ixp4xx):kmod-rfkill $(1)
+  DEPENDS+= +USE_RFKILL:kmod-rfkill $(1)
 endef
 
 
index 44bc870..b9ffaa0 100644 (file)
@@ -239,6 +239,7 @@ $(eval $(call KernelPackage,oprofile))
 define KernelPackage/rfkill
   SUBMENU:=$(OTHER_MENU)
   TITLE:=RF switch subsystem support
+  DEPENDS:=@USE_RFKILL +kmod-input-core
   KCONFIG:= \
     CONFIG_RFKILL \
     CONFIG_RFKILL_INPUT=y \
@@ -247,7 +248,6 @@ define KernelPackage/rfkill
   FILES:= \
     $(LINUX_DIR)/net/rfkill/rfkill.ko
   AUTOLOAD:=$(call AutoLoad,20,rfkill)
-  $(call SetDepends/rfkill,+kmod-input-core)
 endef
 
 define KernelPackage/rfkill/description
index bcc3700..5625b8b 100755 (executable)
@@ -177,6 +177,7 @@ sub target_config_features(@) {
                /powerpc64/ and $ret .= "\tselect powerpc64\n";
                /nommu/ and $ret .= "\tselect NOMMU\n";
                /mips16/ and $ret .= "\tselect HAS_MIPS16\n";
+               /rfkill/ and $ret .= "\tselect RFKILL_SUPPORT\n";
        }
        return $ret;
 }
index a7951aa..7f694e4 100644 (file)
@@ -73,6 +73,9 @@ config HAS_MIPS16
        depends on (mips || mipsel || mips64 || mips64el)
        bool
 
+config RFKILL_SUPPORT
+       bool
+
 config ARCH_64BIT
        bool