lantiq: remove deprecated jffs2_nand configuration
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Jun 2014 18:12:52 +0000 (18:12 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Jun 2014 18:12:52 +0000 (18:12 +0000)
As far as I am aware, amongst the lantiq boards, jffs2_nand was
only used on the BTHOMEHUBV2B. Ubi-related modifications to the
device tree for that board mean that the resulting jffs2 images
no longer work, and are no longer required anyway. So I suggest
removing the related configuration, which this patch does.

If anyone else is using jffs2_nand on a lantiq target please speak
up!

Incidentally, for a jffs2 rootfs partition concatenated to the
kernel image to be recognised and mounted correctly on nand
this patch or something equivalent is required:
http://patchwork.openwrt.org/patch/5110/
It is marked as accepted in patchwork but doesn't seem to have
been committed. As far as I am concerned it too is deprecated.

Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41312 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/image/Makefile
target/linux/lantiq/xway/target.mk

index 3af3d99..7d95061 100644 (file)
@@ -12,7 +12,6 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 JFFS2_BLOCKSIZE = 64k 128k 256k
-NAND_BLOCKSIZE = 512:16k
 
 LOADER_MAKE := $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
 
@@ -171,13 +170,6 @@ define Image/Build/jffs2-256k
        cat $(KDIR)/uImage-$(2)-$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
 endef
 
-define Image/Build/jffs2-nand-512-16k
-       dd if=$(KDIR)/uImage-$(2) of=$(KDIR)/uImage-$(2)-$(1) bs=16k conv=sync
-       $(CP) $(KDIR)/uImage-$(2)-$(1) $(BIN_DIR)/uImage-$(2)-$(1)
-       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/root-$(2)-$(1)
-       cat $(KDIR)/uImage-$(2)-$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
-endef
-
 define Image/Build/ubifs
 
 ifneq ($($(PROFILE)_UBIFS_OPTS),)
index e8a2874..0cc3f8a 100644 (file)
@@ -1,7 +1,7 @@
 ARCH:=mips
 SUBTARGET:=xway
 BOARDNAME:=XWAY
-FEATURES:=squashfs atm mips16 jffs2_nand nand ubifs
+FEATURES:=squashfs atm mips16 nand ubifs
 CPU_TYPE:=34kc
 CPU_SUBTYPE:=dsp