ramips: add support for Zbtlink WA05 router
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Jul 2014 22:02:28 +0000 (22:02 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Jul 2014 22:02:28 +0000 (22:02 +0000)
Signed-off-by: Roman Yeryomin <roman@advem.lv>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41579 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/uci-defaults/01_leds
target/linux/ramips/base-files/etc/uci-defaults/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ZBT-WA05.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index c2f768b..00b6040 100755 (executable)
@@ -181,6 +181,11 @@ case $board in
                ucidef_set_led_default "power" "power" "buffalo:green:power" "1"
                ucidef_set_led_default "router" "router" "buffalo:green:router" "1"
                ;;
+       zbt-wa05)
+               ucidef_set_led_default "power" "power" "zbtlink:blue:power" "1"
+               set_wifi_led "zbtlink:blue:air"
+               set_usb_led "zbtlink:blue:usb"
+               ;;
 esac
 
 ucidef_commit_leds
index 4eef735..a14acb6 100755 (executable)
@@ -112,7 +112,8 @@ ramips_setup_interfaces()
        hg255d | \
        rt-n14u | \
        wrtnode | \
-       ur-326n4g)
+       ur-326n4g | \
+       zbt-wa05)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "switch0" "1" "1"
                ucidef_add_switch_vlan "switch0" "1" "1 2 3 4 6t"
index ca339b3..2ae8c9e 100755 (executable)
@@ -307,6 +307,9 @@ ramips_board_detect() {
        *"Sercomm NA930")
                name="na930"
                ;;
+       *"Zbtlink ZBT-WA05")
+               name="zbt-wa05"
+               ;;
        *)
                name="generic"
                ;;
index a39c433..805a63f 100755 (executable)
@@ -91,7 +91,8 @@ platform_check_image() {
        wmr300 |\
        wrtnode |\
        x5 |\
-       x8)
+       x8 |\
+       zbt-wa05)
                [ "$magic" != "27051956" ] && {
                        echo "Invalid image type."
                        return 1
diff --git a/target/linux/ramips/dts/ZBT-WA05.dts b/target/linux/ramips/dts/ZBT-WA05.dts
new file mode 100644 (file)
index 0000000..714d273
--- /dev/null
@@ -0,0 +1,112 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+       compatible = "zbtlink,zbt-wa05", "ralink,mt7620n-soc";
+       model = "Zbtlink ZBT-WA05";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       palmbus@10000000 {
+               gpio1: gpio@638 {
+                       status = "okay";
+               };
+
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       en25q64@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "w25q64";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x760000>;
+                               };
+                       };
+               };
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "llllw";
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       default {
+                               ralink,group = "i2c", "spi refclk", "wled";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               power {
+                       label = "zbtlink:blue:power";
+                       gpios = <&gpio1 14 1>;
+               };
+               usb {
+                       label = "zbtlink:blue:usb";
+                       gpios = <&gpio1 15 0>;
+               };
+               air {
+                       label = "zbtlink:blue:air";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
index 5b23035..e3ba60e 100644 (file)
@@ -738,12 +738,14 @@ endif
 Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
 Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
 Image/Build/Profile/WRTNODE=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode,WRTNODE)
+Image/Build/Profile/ZBT-WA05=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wa05,ZBT-WA05)
 
 ifeq ($(SUBTARGET),mt7620n)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/WMR300,$(1))
        $(call Image/Build/Profile/RT-N14U,$(1))
        $(call Image/Build/Profile/WRTNODE,$(1))
+       $(call Image/Build/Profile/ZBT-WA05,$(1))
 endef
 endif