[package] base-files: skip LEDs handled by rssileds in led init-script
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Oct 2012 06:45:02 +0000 (06:45 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Oct 2012 06:45:02 +0000 (06:45 +0000)
Without this, /etc/init.d/led will try to set the non-existing 'rssi' trigger.
This doesn't harm as the kernel will refuse this setting, but it outputs some
ugly log-lines:
Jun 24 10:15:19 OpenWrt user.info sysinit: setting up led RSSILOW
Jun 24 10:15:19 OpenWrt user.info sysinit: sh: write error: Invalid argument
...

In order to avoid this, skip LEDs with trigger = "rssi" in /etc/init.d/led

Signed-off-by: Daniel Golle <dgolle@allnet.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33717 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/init.d/led

index 1d56e9f..27ce051 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=117
+PKG_RELEASE:=118
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 43964bf..f3f3c3f 100755 (executable)
@@ -25,6 +25,11 @@ load_led() {
        config_get interval $1 interval "50"
        config_get port_state $1 port_state
 
+       if [ "$trigger" = "rssi" ]; then
+               # handled by rssileds userspace process
+               return
+       fi
+
        [ -e /sys/class/leds/${sysfs}/brightness ] && {
                echo "setting up led ${name}"
                [ "$default" != nil ] && {