target/sdk: generate a Config.in file with the settings of the build that the SDK...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Mar 2014 18:58:49 +0000 (18:58 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Mar 2014 18:58:49 +0000 (18:58 +0000)
This allows make oldconfig/menuconfig to run

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39864 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/sdk/Makefile
target/sdk/convert-config.pl [new file with mode: 0755]
target/sdk/files/Config.in

index 2318f4d..376aef8 100644 (file)
@@ -64,6 +64,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
        rm -rf \
                $(SDK_BUILD_DIR)/target/linux/*/files* \
                $(SDK_BUILD_DIR)/target/linux/*/patches*
        rm -rf \
                $(SDK_BUILD_DIR)/target/linux/*/files* \
                $(SDK_BUILD_DIR)/target/linux/*/patches*
+       ./convert-config.pl $(TOPDIR)/.config > $(SDK_BUILD_DIR)/Config-build.in
        $(CP) -L \
                $(TOPDIR)/LICENSE \
                $(TOPDIR)/rules.mk \
        $(CP) -L \
                $(TOPDIR)/LICENSE \
                $(TOPDIR)/rules.mk \
diff --git a/target/sdk/convert-config.pl b/target/sdk/convert-config.pl
new file mode 100755 (executable)
index 0000000..9fd2c36
--- /dev/null
@@ -0,0 +1,31 @@
+#!/usr/bin/env perl
+use strict;
+
+while (<>) {
+       chomp;
+       next unless /^CONFIG_([^=]+)=(.*)$/;
+
+       my $var = $1;
+       my $val = $2;
+       my $type;
+
+       if ($val eq 'y') {
+               $type = "bool";
+       } elsif ($val eq 'm') {
+               $type = "tristate";
+       } elsif ($val =~ /^".*"$/) {
+               $type = "string";
+       } elsif ($val =~ /^\d+$/) {
+               $type = "int";
+       } else {
+               warn "WARNING: no type found for symbol CONFIG_$var=$val\n";
+               next;
+       }
+
+       print <<EOF;
+config $var
+       $type
+       default $val
+
+EOF
+}
index 214466b..4a2f12e 100644 (file)
@@ -1 +1,2 @@
+source "Config-build.in"
 source "tmp/.config-package.in"
 source "tmp/.config-package.in"