bcm53xx: add support for the Buffalo WXR-1900DHP
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Apr 2015 17:32:25 +0000 (17:32 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Apr 2015 17:32:25 +0000 (17:32 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45419 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/bcm53xx/image/Makefile
target/linux/bcm53xx/patches-3.18/330-ARM-BCM5301X-Add-DT-for-Buffalo-WXR-1900DHP.patch [new file with mode: 0644]

index 0c53c85..cf61317 100644 (file)
@@ -82,6 +82,7 @@ endef
 TARGET_DEVICES += \
        asus-rt-ac56u asus-rt-ac68u asus-rt-ac87u asus-rt-n18u \
        netgear-r6250 netgear-r6300-v2 netgear-r8000 \
-       buffalo-wzr-1750dhp buffalo-wzr-600dhp2 buffalo-wzr-900dhp
+       buffalo-wzr-1750dhp buffalo-wzr-600dhp2 buffalo-wzr-900dhp \
+       buffalo-wxr-1900dhp
 
 $(eval $(call BuildImage))
diff --git a/target/linux/bcm53xx/patches-3.18/330-ARM-BCM5301X-Add-DT-for-Buffalo-WXR-1900DHP.patch b/target/linux/bcm53xx/patches-3.18/330-ARM-BCM5301X-Add-DT-for-Buffalo-WXR-1900DHP.patch
new file mode 100644 (file)
index 0000000..3573256
--- /dev/null
@@ -0,0 +1,156 @@
+From: Felix Fietkau <nbd@openwrt.org>
+Subject: [PATCH] ARM: BCM5301X: Add DT for Buffalo WXR-1900DHP
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+---
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm4709-buffalo-wxr-1900dhp.dts
+@@ -0,0 +1,135 @@
++/*
++ * Broadcom BCM470X / BCM5301X ARM platform code.
++ * DTS for Buffalo WXR-1900DHP
++ *
++ * Copyright (C) 2014 Rafał Miłecki <zajec5@gmail.com>
++ * Copyright (C) 2015 Felix Fietkau <nbd@openwrt.org>
++ *
++ * Licensed under the GNU/GPL. See COPYING for details.
++ */
++
++/dts-v1/;
++
++#include "bcm4708.dtsi"
++
++/ {
++      compatible = "buffalo,wxr-1900dhp", "brcm,bcm4709", "brcm,bcm4708";
++      model = "Buffalo WXR-1900DHP (BCM4709)";
++
++      chosen {
++              bootargs = "console=ttyS0,115200 earlyprintk";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000
++                     0x88000000 0x18000000>;
++      };
++
++      chipcommonA {
++              uart0: serial@0300 {
++                      status = "okay";
++                      clock-frequency = <125000000>;
++              };
++
++              uart1: serial@0400 {
++                      status = "okay";
++                      clock-frequency = <125000000>;
++              };
++      };
++
++      clocks {
++              clk_periph: periph {
++                      clock-frequency = <500000000>;
++              };
++      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              power0 {
++                      label = "bcm53xx:red:power";
++                      gpios = <&chipcommon 5 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-off";
++              };
++
++              power1 {
++                      label = "bcm53xx:white:power";
++                      gpios = <&chipcommon 6 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-on";
++              };
++
++              router0 {
++                      label = "bcm53xx:white:router";
++                      gpios = <&chipcommon 8 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-off";
++              };
++
++              router1 {
++                      label = "bcm53xx:amber:router";
++                      gpios = <&chipcommon 7 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-off";
++              };
++
++              wan0 {
++                      label = "bcm53xx:white:wan";
++                      gpios = <&chipcommon 10 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-off";
++              };
++
++              wan1 {
++                      label = "bcm53xx:amber:wan";
++                      gpios = <&chipcommon 9 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-off";
++              };
++
++              wireless0 {
++                      label = "bcm53xx:white:wireless";
++                      gpios = <&chipcommon 12 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-off";
++              };
++
++              wireless1 {
++                      label = "bcm53xx:amber:wireless";
++                      gpios = <&chipcommon 11 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-off";
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 15 GPIO_ACTIVE_LOW>;
++              };
++
++              aoss {
++                      label = "AOSS";
++                      linux,code = <KEY_WPS_BUTTON>;
++                      gpios = <&chipcommon 16 GPIO_ACTIVE_LOW>;
++              };
++
++              /* Commit mode set by switch? */
++              mode {
++                      label = "Mode";
++                      linux,code = <KEY_SETUP>;
++                      gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
++              };
++
++              /* Switch: AP mode */
++              sw_ap {
++                      label = "AP";
++                      linux,code = <BTN_0>;
++                      gpios = <&chipcommon 18 GPIO_ACTIVE_LOW>;
++              };
++
++              eject {
++                      label = "USB eject";
++                      linux,code = <KEY_EJECTCD>;
++                      gpios = <&chipcommon 20 GPIO_ACTIVE_LOW>;
++              };
++      };
++};
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -64,6 +64,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm47081-asus-rt-n18u.dtb \
+       bcm47081-buffalo-wzr-600dhp2.dtb \
+       bcm47081-buffalo-wzr-900dhp.dtb \
++      bcm4709-buffalo-wxr-1900dhp.dtb \
+       bcm4709-asus-rt-ac87u.dtb \
+       bcm4709-netgear-r8000.dtb
+ dtb-$(CONFIG_ARCH_BCM_63XX) += bcm963138dvt.dtb