Minor kernel build changes:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Feb 2007 19:36:11 +0000 (19:36 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Feb 2007 19:36:11 +0000 (19:36 +0000)
Change '[ -d ... ] && cmd' to 'if [ -d ... ]; then cmd; fi' to avoid make errors if the condition is false
If $(PLATFORM_DIR)/files exists, copy it into the kernel tree on prepare.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6263 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-build.mk

index c0b17aa..1ac847e 100644 (file)
@@ -69,8 +69,9 @@ endif
 
 define Kernel/Prepare/Default
        bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
 
 define Kernel/Prepare/Default
        bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       [ -d $(GENERIC_PLATFORM_DIR)/patches ] && $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches 
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
+       if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi
+       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
+       if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi
 endef
 define Kernel/Prepare
        $(call Kernel/Prepare/Default)
 endef
 define Kernel/Prepare
        $(call Kernel/Prepare/Default)