mvebu: generate a single firmware for the 385-db-ap
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Apr 2015 12:06:56 +0000 (12:06 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Apr 2015 12:06:56 +0000 (12:06 +0000)
This has been done without having a board, but should work.

Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45412 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/mvebu/image/Makefile

index 4431101..191dc27 100644 (file)
@@ -154,6 +154,15 @@ define Image/Build/Profile/Mamba/squashfs
        ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
 endef
 
+define Image/Build/Profile/385-DB-AP/squashfs
+       $(call Image/Build/UbinizeImage,armada-385-db-ap,,squashfs, -p 256KiB -m 4096)
+       ( \
+               dd if=$(KDIR)/uImage-armada-385-db-ap bs=8M conv=sync; \
+               dd if=$(KDIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-ubinized.bin \
+               bs=4096 conv=sync; \
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-factory.img
+endef
+
 # The Default profile should build everything
 $(eval $(call MultiProfile,Default,$(PROFILES_LIST)))