rules.mk: export STAGING_DIR_HOST to sub-makefiles and shells
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Nov 2015 12:52:07 +0000 (12:52 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Nov 2015 12:52:07 +0000 (12:52 +0000)
Certains host packages (like quilt) need to know the previously used
install location at run-time. They currently use $STAGING_DIR, which
causes issues on cleaned environment, where $STAGING_DIR doesn't exist
yet.

Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47409 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk

index 7710fb4..348b45d 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -188,7 +188,7 @@ else
 endif
 
 export PATH:=$(TARGET_PATH)
-export STAGING_DIR
+export STAGING_DIR STAGING_DIR_HOST
 export SH_FUNC:=. $(INCLUDE_DIR)/shell.sh;
 
 PKG_CONFIG:=$(STAGING_DIR_HOST)/bin/pkg-config