brcm2708: define KERNELNAME accordingly
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Feb 2014 20:29:40 +0000 (20:29 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Feb 2014 20:29:40 +0000 (20:29 +0000)
Define KERNELNAME to Image to get the build system to copy this image
over $(KDIR) automatically for us.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39768 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm2708/Makefile
target/linux/brcm2708/image/Makefile

index 8ab34eb..f83d6f5 100644 (file)
@@ -25,4 +25,6 @@ define Target/Description
        Currently produces SD Card image for Raspberry Pi.
 endef
 
+KERNELNAME="Image"
+
 $(eval $(call BuildTarget))
index 6b4cf14..ae977a6 100644 (file)
@@ -8,10 +8,6 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 include $(INCLUDE_DIR)/host.mk
 
-define Image/Prepare
-       cp $(LINUX_DIR)/arch/arm/boot/Image $(KDIR)/Image
-endef
-
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))