oxnas/kd20: use gpio-beeper
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 2 Dec 2014 15:25:09 +0000 (15:25 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 2 Dec 2014 15:25:09 +0000 (15:25 +0000)
gpio-beeper module was added to the kernel recently.
Make use of it to drive the piezoelectric buzzer of the kd20.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43496 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/oxnas/files/arch/arm/boot/dts/ox820-kd20.dts
target/linux/oxnas/profiles/100-Generic.mk

index e7ee587..9f52f43 100644 (file)
                        label = "kd20:blue:usb";
                        gpios = <&GPIOB 8 0>;
                };
                        label = "kd20:blue:usb";
                        gpios = <&GPIOB 8 0>;
                };
-               buzzer {
-                       label = "kd20:buzzer";
-                       gpios = <&GPIOB 11 0>;
-               };
+       };
+
+       beeper: beeper {
+               compatible = "gpio-beeper";
+               gpios = <&GPIOB 11 0>;
        };
 
        gpio-fan {
        };
 
        gpio-fan {
index 734b123..d5ec97d 100644 (file)
@@ -40,7 +40,7 @@ endef
 define Profile/KD20
   NAME:=Shuttle KD20
   PACKAGES:= \
 define Profile/KD20
   NAME:=Shuttle KD20
   PACKAGES:= \
-       uboot-envtools kmod-usb2-oxnas kmod-usb3 kmod-rtc-pcf8563
+       uboot-envtools kmod-usb2-oxnas kmod-usb3 kmod-rtc-pcf8563 kmod-gpio-beeper
 endef
 
 define Profile/KD20/Description
 endef
 
 define Profile/KD20/Description