compile fix for 2.6
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 22 Jan 2007 01:08:29 +0000 (01:08 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 22 Jan 2007 01:08:29 +0000 (01:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6170 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/pwc/Makefile
package/pwc/patches/100-compile_fix.patch [new file with mode: 0644]

index 934d6b7..52daff0 100644 (file)
@@ -25,7 +25,7 @@ define KernelPackage/pwc
   TITLE:=USB Philips camera driver
   DESCRIPTION:=Kernel support for USB Philips camera
   SUBMENU:=USB Support
-  DEPENDS:=@BROKEN @LINUX_2_6
+  DEPENDS:=@LINUX_2_6 @VIDEO_SUPPORT
   VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/pwc.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,70,$(shell cat ./files/pwc.modules))
diff --git a/package/pwc/patches/100-compile_fix.patch b/package/pwc/patches/100-compile_fix.patch
new file mode 100644 (file)
index 0000000..fc12c75
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ur pwc.old/pwc.h pwc.dev/pwc.h
+--- pwc.old/pwc.h      2006-04-13 23:38:43.000000000 +0200
++++ pwc.dev/pwc.h      2007-01-22 02:04:03.872800960 +0100
+@@ -25,7 +25,7 @@
+ #ifndef PWC_H
+ #define PWC_H
+-#include <linux/config.h>
++#include <linux/autoconf.h>
+ #include <linux/module.h>
+ #include <linux/usb.h>
+ #include <linux/spinlock.h>
+diff -ur pwc.old/pwc-uncompress.h pwc.dev/pwc-uncompress.h
+--- pwc.old/pwc-uncompress.h   2006-01-07 12:57:47.000000000 +0100
++++ pwc.dev/pwc-uncompress.h   2007-01-22 02:04:18.129633592 +0100
+@@ -30,7 +30,7 @@
+ #ifndef PWC_UNCOMPRESS_H
+ #define PWC_UNCOMPRESS_H
+-#include <linux/config.h>
++#include <linux/autoconf.h>
+ #include "pwc-ioctl.h"