add a second parameter to InstallDev/UninstallDev for specifying the path to STAGING_...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Dec 2007 00:41:40 +0000 (00:41 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Dec 2007 00:41:40 +0000 (00:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9853 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package.mk

index 90750fe..9ab3a2c 100644 (file)
@@ -70,7 +70,7 @@ define Build/DefaultTargets
        touch $$@
 
   $(STAMP_INSTALLED): $(STAMP_BUILT)
-       $(call Build/InstallDev,$(STAGING_DIR))
+       $(call Build/InstallDev,$(STAGING_DIR),$(STAGING_DIR_HOST))
        touch $$@
 
   ifdef Build/InstallDev
@@ -160,7 +160,7 @@ configure:
 compile:
 install:
 clean: FORCE
-       $(call Build/UninstallDev,$(STAGING_DIR))
+       $(call Build/UninstallDev,$(STAGING_DIR),$(STAGING_DIR_HOST))
        $(Build/Clean)
        @rm -f $(STAGING_DIR)/stamp/.$(PKG_NAME)-installed
        @rm -rf $(PKG_BUILD_DIR)