odhcp6c: Send RS on start
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Jan 2013 18:06:24 +0000 (18:06 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Jan 2013 18:06:24 +0000 (18:06 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35137 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.script

index f97e6ac..1a3296d 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-01-11
+PKG_VERSION:=2013-01-13
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 8f258f5..859ae1b 100755 (executable)
@@ -19,6 +19,9 @@ prepare_interface() {
 
        ipv6_conf "$device" accept_ra 2
        ipv6_conf "$device" forwarding 2
+
+       # Send RS
+       [ -x /usr/sbin/6relayd ] && /usr/sbin/6relayd -s "$device"
 }
 
 cleanup_interface() {