[buildroot] fix for GREP_OPTIONS
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 31 Jul 2010 22:32:21 +0000 (22:32 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 31 Jul 2010 22:32:21 +0000 (22:32 +0000)
When using GREP_OPTIONS to supply default options to grep, the buildsystem might get broken (For example adding --color=always breaks it)
This patch will empty the GREP_OPTIONS to prevent the described (and any other) problems related to GREP_OPTIONS

Signed-off-by: Maarten Bezemer <m.m.bezemer@utwente.nl>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22443 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
rules.mk

index db79274..31042b2 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,8 @@ ifneq ($(OPENWRT_BUILD),1)
 
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
+  GREP_OPTIONS=
+  export GREP_OPTIONS
   include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
index 0cb72ac..2add087 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -18,6 +18,9 @@ TMP_DIR:=$(TOPDIR)/tmp
 
 export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
 
+GREP_OPTIONS=
+export GREP_OPTIONS
+
 qstrip=$(strip $(subst ",,$(1)))
 #"))