tools: add sdimage for mxs
authorwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Sep 2015 21:08:08 +0000 (21:08 +0000)
committerwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Sep 2015 21:08:08 +0000 (21:08 +0000)
This tool is used for SD card generation on Freescale i.MX23/i.MX28
platforms. These CPU's ROM need a tiny header of front of a boot stream.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47020 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/sdimage/Makefile [new file with mode: 0644]

index dda429f..df384d4 100644 (file)
@@ -31,7 +31,7 @@ tools-y += mm-macros missing-macros xz cmake scons bc findutils gengetopt patche
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_powerpc) += upx
 tools-$(CONFIG_TARGET_x86) += qemu
-tools-$(CONFIG_TARGET_mxs) += elftosb
+tools-$(CONFIG_TARGET_mxs) += elftosb sdimage
 tools-$(CONFIG_TARGET_brcm2708)$(CONFIG_TARGET_sunxi)$(CONFIG_TARGET_mxs) += mtools dosfstools
 tools-$(CONFIG_TARGET_ar71xx) += lzma-old squashfs
 tools-y += lzma squashfs4
diff --git a/tools/sdimage/Makefile b/tools/sdimage/Makefile
new file mode 100644 (file)
index 0000000..e590417
--- /dev/null
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=imx-uuc
+PKG_VERSION=2015-09-13-$(PKG_SOURCE_VERSION)
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/mhei/fsl-imx-uuc.git
+PKG_SOURCE_VERSION:=2b99403b6dc60a22b07eb7a5cc0cb184abb89bdd
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.bz2
+
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=LICENSE
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_SOURCE_SUBDIR)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/sdimage $(STAGING_DIR_HOST)/bin/sdimage
+endef
+
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/sdimage
+endef
+
+$(eval $(call HostBuild))