[brcm47xx] update profiles
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2012 21:54:06 +0000 (21:54 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2012 21:54:06 +0000 (21:54 +0000)
* add profile for BCM4705 based SoC using tg3 instead of b44
* remove redundant 105-Atheros.mk
* reorder

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33235 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm47xx/profiles/100-Broadcom-b43.mk
target/linux/brcm47xx/profiles/101-Broadcom-wl.mk
target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk [new file with mode: 0644]
target/linux/brcm47xx/profiles/105-Atheros.mk [deleted file]
target/linux/brcm47xx/profiles/105-Broadcom-none.mk [new file with mode: 0644]
target/linux/brcm47xx/profiles/106-Atheros-ath5k.mk [deleted file]
target/linux/brcm47xx/profiles/110-Bcm4705-b43.mk [new file with mode: 0644]
target/linux/brcm47xx/profiles/110-None.mk [deleted file]
target/linux/brcm47xx/profiles/115-Bcm4705-none.mk [new file with mode: 0644]

index df8d37b..7880ce8 100644 (file)
@@ -12,7 +12,7 @@ endef
 
 define Profile/Broadcom-b43/Description
        Package set compatible with hardware using Broadcom BCM43xx cards
-       using the MAC80211 b43 and b43legacy drivers.
+       using the MAC80211 b43 and b43legacy drivers and b44 Ethernet driver.
 endef
 
 $(eval $(call Profile,Broadcom-b43))
index d67298c..1464b7e 100644 (file)
@@ -12,7 +12,8 @@ endef
 
 define Profile/Broadcom-wl/Description
        Package set compatible with hardware using Broadcom BCM43xx cards
-       using the proprietary broadcom wireless "wl" driver.
+       using the proprietary broadcom wireless "wl" driver and b44 Ethernet
+       driver.
 endef
 
 $(eval $(call Profile,Broadcom-wl))
diff --git a/target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk b/target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk
new file mode 100644 (file)
index 0000000..32baa08
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-ath5k
+  NAME:=Atheros WiFi (ath5k)
+  PACKAGES:=kmod-ath5k
+endef
+
+define Profile/Atheros/Description
+       Package set compatible with hardware using Atheros WiFi cards and
+       b44 Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-ath5k))
+
diff --git a/target/linux/brcm47xx/profiles/105-Atheros.mk b/target/linux/brcm47xx/profiles/105-Atheros.mk
deleted file mode 100644 (file)
index f47a361..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Atheros
-  NAME:=Atheros WiFi (ath5k)
-  PACKAGES:=kmod-ath5k
-endef
-
-define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros))
-
diff --git a/target/linux/brcm47xx/profiles/105-Broadcom-none.mk b/target/linux/brcm47xx/profiles/105-Broadcom-none.mk
new file mode 100644 (file)
index 0000000..04ad25d
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-none
+  NAME:=No WiFi
+  PACKAGES:=-wpad-mini
+endef
+
+define Profile/None/Description
+       Package set without WiFi support and b44 Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-none))
+
diff --git a/target/linux/brcm47xx/profiles/106-Atheros-ath5k.mk b/target/linux/brcm47xx/profiles/106-Atheros-ath5k.mk
deleted file mode 100644 (file)
index fe5a989..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Atheros-ath5k
-  NAME:=Atheros WiFi (ath5k)
-  PACKAGES:=kmod-ath5k
-endef
-
-define Profile/Atheros-ath5k/Description
-       Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros-ath5k))
-
diff --git a/target/linux/brcm47xx/profiles/110-Bcm4705-b43.mk b/target/linux/brcm47xx/profiles/110-Bcm4705-b43.mk
new file mode 100644 (file)
index 0000000..f5bdaac
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Bcm4705-b43
+  NAME:=BCM4705/BCM4785, Broadcom BCM43xx WiFi (b43)
+  PACKAGES:=kmod-b43 kmod-b43legacy kmod-tg3 kmod-ssb-gige
+endef
+
+define Profile/Broadcom-b43/Description
+       Package set compatible with hardware using Broadcom BCM43xx cards
+       using the MAC80211 b43 and b43legacy drivers and tg3 Ethernet driver
+endef
+
+$(eval $(call Profile,Bcm4705-b43))
+
diff --git a/target/linux/brcm47xx/profiles/110-None.mk b/target/linux/brcm47xx/profiles/110-None.mk
deleted file mode 100644 (file)
index 73df59b..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/None
-  NAME:=No WiFi
-  PACKAGES:=-wpad-mini
-endef
-
-define Profile/None/Description
-       Package set without WiFi support
-endef
-$(eval $(call Profile,None))
-
diff --git a/target/linux/brcm47xx/profiles/115-Bcm4705-none.mk b/target/linux/brcm47xx/profiles/115-Bcm4705-none.mk
new file mode 100644 (file)
index 0000000..5b03f2c
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Bcm4705-none
+  NAME:=BCM4705/BCM4785, no WiFi
+  PACKAGES:=-wpad-mini kmod-tg3 kmod-ssb-gige
+endef
+
+define Profile/None/Description
+       Package set without WiFi support and tg3 Ethernet driver.
+endef
+$(eval $(call Profile,Bcm4705-none))
+