ath10k: remove support for the obsolete STA firmware
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Jul 2015 10:21:26 +0000 (10:21 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Jul 2015 10:21:26 +0000 (10:21 +0000)
Current firmware should work for station mode as well, and the older
firmware will usually behave worse and become unsupported over time.
Also, the MAC address handling on ar71xx is only implemented on one
firmware version.

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46197 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/mac80211/Makefile

index de82118..f7f7401 100644 (file)
@@ -621,19 +621,6 @@ Atheros IEEE 802.11ac family of chipsets. For now only
 PCI is supported.
 endef
 
-define KernelPackage/ath10k/config
-  if PACKAGE_kmod-ath10k
-
-       config ATH10K_STA_FW
-               bool "Firmware optimized for STA operation"
-               default n
-               help
-                 Use the ath10k firmware optimized for wireless client instead
-                 of access point operation.
-
-  endif
-endef
-
 define KernelPackage/carl9170
   $(call KernelPackage/mac80211/Default)
   TITLE:=Driver for Atheros AR9170 USB sticks
@@ -1858,15 +1845,9 @@ define KernelPackage/ath10k/install
        $(INSTALL_DATA) \
                $(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/ath10k/QCA988X/hw2.0/board.bin \
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/
-ifeq ($(CONFIG_ATH10K_STA_FW),y)
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/main/firmware-2.bin_999.999.0.636 \
-               $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-2.bin
-else
        $(INSTALL_DATA) \
                $(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/10.2.4/untested/firmware-5.bin_10.2.4.70-2 \
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
-endif
 endef
 
 define KernelPackage/mwl8k/install