realview: fix zImage-initramfs installation
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Feb 2014 00:12:53 +0000 (00:12 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Feb 2014 00:12:53 +0000 (00:12 +0000)
We were copying the actual vmlinux-initramfs.elf kernel which cannot be
launched by QEMU or a real bootloader, use zImage-initramfs instead.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39756 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/realview/image/Makefile

index dd0d9ee..c6ff8ce 100644 (file)
@@ -8,7 +8,11 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/BuildKernel
 include $(INCLUDE_DIR)/image.mk
 
 define Image/BuildKernel
-       cp $(LINUX_DIR)/arch/$(ARCH)/boot/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+       cp $(KDIR)/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+define Image/BuildKernel/Initramfs
+       cp $(KDIR)/$(subst ",,$(KERNELNAME))-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
 endef
 
 define Image/Build/squashfs
 endef
 
 define Image/Build/squashfs