[package] ppp: add workaround for ignored rp_pppoe_ac and rp_pppoe_service options...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 4 Oct 2011 23:10:36 +0000 (23:10 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 4 Oct 2011 23:10:36 +0000 (23:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28364 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ppp/Makefile
package/ppp/files/ppp.sh
package/ppp/files/pppoe.sh

index eed5943..ed69210 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index 996d542..7c789fc 100644 (file)
@@ -16,6 +16,13 @@ stop_interface_ppp() {
 start_pppd() {
        local cfg="$1"; shift
 
+       # Workaround for PPPoE service and AC name options,
+       # filter out the nic-* argument and append it as last option
+       local nic=""
+       case "$1" in
+               nic-*) nic="$1"; shift ;;
+       esac
+
        local proto
        config_get proto "$cfg" proto
 
@@ -110,7 +117,8 @@ start_pppd() {
                ${disconnect:+disconnect "$disconnect"} \
                ${ipv6} \
                ${pppd_options} \
-               nodetach
+               nodetach \
+               ${nic}
 
        lock -u "/var/lock/ppp-${link}"
 }
index bbd36a1..99409f3 100644 (file)
@@ -13,7 +13,7 @@ setup_interface_pppoe() {
        config_get mtu "$config" mtu
        mtu=${mtu:-1492}
        start_pppd "$config" \
+               "nic-$iface" \
                plugin rp-pppoe.so \
-               mtu $mtu mru $mtu \
-               "nic-$iface"
+               mtu $mtu mru $mtu
 }