[toolchain] provide a cleaner way to specify a biarch toolchain build
authorjk <jk@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Apr 2008 23:14:42 +0000 (23:14 +0000)
committerjk <jk@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Apr 2008 23:14:42 +0000 (23:14 +0000)
Currently, to build a biarch toolchain, we need to explicitly give
options to the binutils and gcc configure commands:

CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS="--enable-targets=powerpc64-linux-uclibc"
CONFIG_EXTRA_GCC_CONFIG_OPTIONS="--enable-biarch --enable-targets=powerpc64-linux-uclibc"

This change replaces the command line options with an 'extra arch'
configure option:

CONFIG_EXTRA_TARGET_ARCH=y
CONFIG_EXTRA_TARGET_ARCH_NAME="powerpc64"

And a way to invoke this extra arch on the compiler command-line:

CONFIG_EXTRA_TARGET_ARCH_OPTS="-m64"

In this case, this results in an extra compiler:
 'powerpc64-linux-uclibc-gcc', which invokes
 'powerpc-linux-uclibc-gcc -m64'

This is a more standard way of building biarch toolchains, and allows
the packages to not have to care about how to invoke the 64-bit
compiler.

Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10802 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/Config.in
toolchain/binutils/Makefile
toolchain/gcc/Makefile
toolchain/gcc/files/alternate-arch-cc.in [new file with mode: 0644]

index 192818f..c4f6e14 100644 (file)
@@ -10,6 +10,35 @@ menuconfig TOOLCHAINOPTS
        bool "Toolchain Options" if DEVEL
        depends !NATIVE_TOOLCHAIN
 
+menuconfig EXTRA_TARGET_ARCH
+       bool
+       prompt "Enable an extra toolchain target architecture" if TOOLCHAINOPTS
+       default n
+       help
+         Some builds may require a 'biarch' toolchain. This option
+         allows you to specify an additional target arch.
+
+         Most people will answer N here.
+
+       config EXTRA_TARGET_ARCH_NAME
+               string
+               prompt "Extra architecture name" if EXTRA_TARGET_ARCH
+               help
+                 Specify the cpu name (eg powerpc64 or x86_64) of the
+                 additional target architecture.
+
+       config EXTRA_TARGET_ARCH_OPTS
+               string
+               prompt "Extra architecture compiler options" if EXTRA_TARGET_ARCH
+               help
+                 If you're specifying an addition target architecture,
+                 you'll probably need to also provide options to make
+                 the compiler use this alternate arch.
+
+                 For example, if you're building a compiler that can build
+                 both powerpc and powerpc64 binaries, you'll need to
+                 specify -m64 here.
+
 source "toolchain/binutils/Config.in"
 source "toolchain/gcc/Config.in"
 source "toolchain/uClibc/Config.in"
index b3161b3..8682fa5 100644 (file)
@@ -24,6 +24,8 @@ BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
 
 include $(INCLUDE_DIR)/host-build.mk
 
+EXTRA_TARGET=$(if $(CONFIG_EXTRA_TARGET_ARCH),--enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-uclibc)
+
 define Build/Configure
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/
        (cd $(PKG_BUILD_DIR); \
@@ -34,6 +36,7 @@ define Build/Configure
                --target=$(REAL_GNU_TARGET_NAME) \
                --disable-werror \
                --disable-nls \
+               $(EXTRA_TARGET) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
        );
index a1d1baa..875c375 100644 (file)
@@ -40,6 +40,8 @@ BUILD_DIR2:=$(BUILD_DIR_HOST)/gcc-$(PKG_VERSION)-final
 SEP:=,
 TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
 
+EXTRA_TARGET=$(if $(CONFIG_EXTRA_TARGET_ARCH),--enable-biarch --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-uclibc)
+
 define Stage1/Configure
        $(SED) 's,TARGET_CROSS=.*,TARGET_CROSS=$(REAL_GNU_TARGET_NAME)-,' $(TOOLCHAIN_DIR)/info.mk
        $(SED) 's,GCC_VERSION=.*,GCC_VERSION=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
@@ -60,6 +62,7 @@ define Stage1/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               $(EXTRA_TARGET) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
        );
@@ -93,6 +96,7 @@ define Stage2/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               $(EXTRA_TARGET) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
        );
@@ -102,6 +106,19 @@ define Stage2/Compile
        export SHELL="\$(BASH)"; \$(MAKE) -C \$(BUILD_DIR2) all
 endef
 
+define SetupExtraArch
+       for app in $(TOOLCHAIN_DIR)/bin/$(OPTIMIZE_FOR_CPU)*-{gcc,gcc-*,g++}; do \
+               [ -e $$$$app ] || continue; \
+               old_base=$$$$(basename $$$$app); \
+               new_base=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-$$$${old_base##$(OPTIMIZE_FOR_CPU)-}; \
+               sed -e "s/@CC_BASE@/$$$$old_base/" \
+                       -e 's/@EXTRA_ARCH_OPTS@/$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_OPTS))/' \
+                        ./files/alternate-arch-cc.in > \
+                        $(TOOLCHAIN_DIR)/bin/$$$$new_base; \
+               chmod a+x $(TOOLCHAIN_DIR)/bin/$$$$new_base; \
+       done
+endef
+
 define Stage2/Install
        $(MAKE) -C $(BUILD_DIR2) \
                SHELL="$(BASH)" \
@@ -116,6 +133,7 @@ define Stage2/Install
                        $(GNU_TARGET_NAME)$$$${app##$(REAL_GNU_TARGET_NAME)}; \
                done; \
        );
+       $(if $(CONFIG_EXTRA_TARGET_ARCH),$(call SetupExtraArch))
 endef
 
 define Build/Prepare
diff --git a/toolchain/gcc/files/alternate-arch-cc.in b/toolchain/gcc/files/alternate-arch-cc.in
new file mode 100644 (file)
index 0000000..e169951
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec @CC_BASE@ @EXTRA_ARCH_OPTS@ "$@"