ramips: rt305x: build image for the DIR-615 rev D boards
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 27 Mar 2012 19:29:59 +0000 (19:29 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 27 Mar 2012 19:29:59 +0000 (19:29 +0000)
Patch from #10105.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31101 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c
target/linux/ramips/image/Makefile

index b101dcd..bce51cd 100644 (file)
@@ -25,6 +25,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_DIR_300_B1,         /* D-Link DIR-300 B1 */
        RAMIPS_MACH_DIR_600_B1,         /* D-Link DIR-600 B1 */
        RAMIPS_MACH_DIR_600_B2,         /* D-Link DIR-600 B2 */
+       RAMIPS_MACH_DIR_615_D,          /* D-Link DIR-615 D */
        RAMIPS_MACH_RT_G32_B1,          /* Asus RT-G32 B1 */
        RAMIPS_MACH_RT_N10_PLUS,        /* Asus RT-N10+ */
        RAMIPS_MACH_NW718,              /* Netcore NW718 */
index 4db89b3..3581972 100644 (file)
@@ -88,3 +88,6 @@ MIPS_MACHINE(RAMIPS_MACH_DIR_600_B1, "DIR-600-B1", "D-Link DIR-600 B1",
 
 MIPS_MACHINE(RAMIPS_MACH_DIR_600_B2, "DIR-600-B2", "D-Link DIR-600 B2",
             dir_300b_init);
+
+MIPS_MACHINE(RAMIPS_MACH_DIR_615_D, "DIR-615-D", "D-Link DIR-615 D",
+            dir_300b_init);
index 3499c9e..a4d526d 100644 (file)
@@ -312,6 +312,7 @@ define Image/Build/Profile/DIR300B1
        $(call Image/Build/Template/$(fs_squash)/$(1),DIR300B1,dir-300-b1,DIR-300-B1,wrgn23_dlwbr_dir300b)
        $(call Image/Build/Template/$(fs_squash)/$(1),DIR300B1,dir-600-b1,DIR-600-B1,wrgn23_dlwbr_dir600b)
        $(call Image/Build/Template/$(fs_squash)/$(1),DIR300B1,dir-600-b2,DIR-600-B2,wrgn23_dlwbr_dir600b)
+       $(call Image/Build/Template/$(fs_squash)/$(1),DIR300B1,dir-615-d,DIR-615-D,wrgn23_dlwbr_dir615d)
 endef
 
 define Image/Build/Profile/ESR9753