ramips: disable ill_acc driver by default
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Jul 2013 18:01:00 +0000 (18:01 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Jul 2013 18:01:00 +0000 (18:01 +0000)
The driver seems to be causoing boot rpoblems on some SoCs

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37314 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/mt7620a/config-3.9
target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch
target/linux/ramips/rt288x/config-3.9
target/linux/ramips/rt305x/config-3.9
target/linux/ramips/rt3883/config-3.9

index ea7d6bc..de16bf0 100644 (file)
@@ -138,6 +138,7 @@ CONFIG_PERF_USE_VMALLOC=y
 CONFIG_PHYLIB=y
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
 CONFIG_RALINK_USBPHY=y
 CONFIG_RALINK_WDT=y
 # CONFIG_RCU_STALL_COMMON is not set
index c82b7a9..e29a52d 100644 (file)
@@ -10,19 +10,23 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  2 files changed, 88 insertions(+), 1 deletion(-)
  create mode 100644 arch/mips/ralink/ill_acc.c
 
---- a/arch/mips/ralink/Makefile
-+++ b/arch/mips/ralink/Makefile
-@@ -6,7 +6,7 @@
- # Copyright (C) 2009-2011 Gabor Juhos <juhosg@openwrt.org>
- # Copyright (C) 2013 John Crispin <blogic@openwrt.org>
+Index: linux-3.9.10/arch/mips/ralink/Makefile
+===================================================================
+--- linux-3.9.10.orig/arch/mips/ralink/Makefile        2013-07-14 10:54:04.242545881 +0200
++++ linux-3.9.10/arch/mips/ralink/Makefile     2013-07-14 11:42:58.726615805 +0200
+@@ -8,6 +8,8 @@
  
--obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o
-+obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o ill_acc.o
+ obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o
  
++obj-$(CONFIG_RALINK_ILL_ACC) += ill_acc.o
++
  obj-$(CONFIG_SOC_RT288X) += rt288x.o
  obj-$(CONFIG_SOC_RT305X) += rt305x.o
---- /dev/null
-+++ b/arch/mips/ralink/ill_acc.c
+ obj-$(CONFIG_SOC_RT3883) += rt3883.o
+Index: linux-3.9.10/arch/mips/ralink/ill_acc.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ linux-3.9.10/arch/mips/ralink/ill_acc.c    2013-07-14 10:54:04.318545882 +0200
 @@ -0,0 +1,87 @@
 +/*
 + * This program is free software; you can redistribute it and/or modify it
index 561f871..598c972 100644 (file)
@@ -121,6 +121,7 @@ CONFIG_PERF_USE_VMALLOC=y
 CONFIG_PHYLIB=y
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
 # CONFIG_RALINK_USBPHY is not set
 CONFIG_RALINK_WDT=y
 # CONFIG_RCU_STALL_COMMON is not set
index 72c6082..eb5232b 100644 (file)
@@ -123,6 +123,7 @@ CONFIG_PERF_USE_VMALLOC=y
 CONFIG_PHYLIB=y
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
 CONFIG_RALINK_USBPHY=y
 CONFIG_RALINK_WDT=y
 # CONFIG_RCU_STALL_COMMON is not set
index 8bf4915..3db5077 100644 (file)
@@ -128,6 +128,7 @@ CONFIG_PERF_USE_VMALLOC=y
 CONFIG_PHYLIB=y
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
 CONFIG_RALINK_USBPHY=y
 CONFIG_RALINK_WDT=y
 # CONFIG_RCU_STALL_COMMON is not set