nuke util-linux in favor of util-linux-ng, build only what we need
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Oct 2007 09:57:57 +0000 (09:57 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Oct 2007 09:57:57 +0000 (09:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9444 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/util-linux-ng/Makefile [new file with mode: 0644]
package/util-linux/Makefile [deleted file]
package/util-linux/patches/100-llseek.patch [deleted file]
package/util-linux/patches/501-mconfig.patch [deleted file]
package/util-linux/patches/601-util-linux-2.12r-umount-no-special.patch [deleted file]
package/util-linux/patches/801-cris_avr32_label.patch [deleted file]

diff --git a/package/util-linux-ng/Makefile b/package/util-linux-ng/Makefile
new file mode 100644 (file)
index 0000000..103e790
--- /dev/null
@@ -0,0 +1,119 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=util-linux-ng
+PKG_VERSION:=2.13.0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.13
+PKG_MD5SUM:=c841dc8743905c8f0db20c9db5094f57
+
+PKG_BUILD_DEPENDS=libblkid libuuid
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/util-linux/Default
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@!TARGET_etrax
+  URL:=http://www.kernel.org/pub/linux/utils/util-linux-ng/
+endef
+
+define Package/fdisk
+$(call Package/util-linux/Default)
+  TITLE:=Partition table manipulation utility
+  SUBMENU=disc
+endef
+
+define Package/fdisk/description
+ This package contains a utility for managing disk partition tables.
+endef
+
+define Package/cfdisk
+$(call Package/util-linux/Default)
+  TITLE:=Partition table manipulation utility
+  DEPENDS:= +libncurses
+  SUBMENU:=disc
+endef
+
+define Package/cfdisk/description
+ This package contains a utility for managing disk partition tables.
+endef
+
+define Package/losetup
+$(call Package/util-linux/Default)
+  TITLE:=Loopback devices setup and control utility
+endef
+
+define Package/losetup/description
+ This package contains a utility for managing loopback devices.
+endef
+
+define Package/swap-utils
+$(call Package/util-linux/Default)
+  TITLE:=Swap space management utilities
+  SUBMENU:=disc
+endef
+
+define Package/swap-utils/description
+ This package contains a collection of tools for managing swap space: 
+ - mkswap
+ - swapon
+ - swapoff
+endef
+
+define Package/hwclock
+$(call Package/util-linux/Default)
+  TITLE:=Utilities for managing the hardware clock
+endef
+
+define Package/hwclock/description
+ This package contains a utility for managing the hardware clock.
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)/disk-utils mkswap
+       $(MAKE) -C $(PKG_BUILD_DIR)/mount swapon losetup
+       $(MAKE) -C $(PKG_BUILD_DIR)/fdisk fdisk cfdisk
+       $(MAKE) -C $(PKG_BUILD_DIR)/hwclock hwclock
+endef
+
+define Package/fdisk/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/fdisk $(1)/usr/sbin/
+endef
+
+define Package/cfdisk/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/cfdisk $(1)/usr/sbin/
+endef
+
+define Package/losetup/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/losetup $(1)/usr/sbin/
+endef
+
+define Package/swap-utils/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/mkswap $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/swapon $(1)/usr/sbin/
+       ln -sf swapon $(1)/usr/sbin/swapoff
+endef
+
+define Package/hwclock/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,fdisk))
+$(eval $(call BuildPackage,cfdisk))
+$(eval $(call BuildPackage,losetup))
+$(eval $(call BuildPackage,swap-utils))
+$(eval $(call BuildPackage,hwclock))
diff --git a/package/util-linux/Makefile b/package/util-linux/Makefile
deleted file mode 100644 (file)
index 602d1d5..0000000
+++ /dev/null
@@ -1,133 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=util-linux
-PKG_VERSION:=2.12r
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/
-PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/util-linux/Default
-  SECTION:=utils
-  CATEGORY:=Utilities
-  DEPENDS:=@!TARGET_etrax
-  URL:=http://www.kernel.org/pub/linux/utils/util-linux/
-endef
-
-define Package/fdisk
-$(call Package/util-linux/Default)
-  TITLE:=Partition table manipulation utility
-  SUBMENU=disc
-endef
-
-define Package/fdisk/description
- This package contains a utility for managing disk partition tables.
-endef
-
-define Package/cfdisk
-$(call Package/util-linux/Default)
-  TITLE:=Partition table manipulation utility
-  DEPENDS:= +libncurses
-  SUBMENU:=disc
-endef
-
-define Package/cfdisk/description
- This package contains a utility for managing disk partition tables.
-endef
-
-define Package/losetup
-$(call Package/util-linux/Default)
-  TITLE:=Loopback devices setup and control utility
-endef
-
-define Package/losetup/description
- This package contains a utility for managing loopback devices.
-endef
-
-define Package/swap-utils
-$(call Package/util-linux/Default)
-  TITLE:=Swap space management utilities
-  SUBMENU:=disc
-endef
-
-define Package/swap-utils/description
- This package contains a collection of tools for managing swap space: 
- - mkswap
- - swapon
- - swapoff
-endef
-
-define Package/hwclock
-$(call Package/util-linux/Default)
-  TITLE:=Utilities for managing the hardware clock
-endef
-
-define Package/hwclock/description
- This package contains a utility for managing the hardware clock.
-endef
-
-define Build/Configure
-       # this is NOT GNU configure!
-       ( cd $(PKG_BUILD_DIR); \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
-               ./configure \
-       );
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               OPT="$(TARGET_CFLAGS)" \
-               INSTALLSUID="install -m 4755" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/Template
-       @if [ \! -f "$(PKG_INSTALL_DIR)/$(1)" ]; then \
-               rm -f $(PKG_BUILD_DIR)/.built; \
-               $(MAKE) $(PKG_BUILD_DIR)/.built; \
-       fi
-       $(INSTALL_DIR) $(2)
-       $(CP) $(PKG_INSTALL_DIR)/$(1) $(2)/
-endef
-
-define Package/fdisk/install
-       $(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
-endef
-
-define Package/cfdisk/install
-       $(call Package/Template,sbin/cfdisk,$(1)/usr/sbin)
-endef
-
-define Package/losetup/install
-       $(call Package/Template,sbin/losetup,$(1)/usr/sbin)
-endef
-
-define Package/swap-utils/install
-       $(call Package/Template,sbin/mkswap,$(1)/usr/sbin)
-       $(call Package/Template,sbin/swapon,$(1)/usr/sbin)
-       $(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
-endef
-
-define Package/hwclock/install
-       $(call Package/Template,sbin/hwclock,$(1)/usr/sbin)
-endef
-
-$(eval $(call BuildPackage,fdisk))
-$(eval $(call BuildPackage,cfdisk))
-$(eval $(call BuildPackage,losetup))
-$(eval $(call BuildPackage,swap-utils))
-$(eval $(call BuildPackage,hwclock))
diff --git a/package/util-linux/patches/100-llseek.patch b/package/util-linux/patches/100-llseek.patch
deleted file mode 100644 (file)
index 265aa18..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-Index: util-linux-2.12r/fdisk/llseek.c
-===================================================================
---- util-linux-2.12r.orig/fdisk/llseek.c       2007-06-04 13:22:28.258559328 +0200
-+++ util-linux-2.12r/fdisk/llseek.c    2007-06-04 13:22:28.339547016 +0200
-@@ -29,16 +29,10 @@
- static int _llseek (unsigned int, unsigned long,
-                  unsigned long, long long *, unsigned int);
--#ifdef __NR__llseek
--
--static _syscall5(int,_llseek,unsigned int,fd,unsigned long,offset_high,
--               unsigned long, offset_low,long long *,result,
--               unsigned int, origin)
--
--#else
-+#ifndef __NR__llseek
- /* no __NR__llseek on compilation machine - might give it explicitly */
--static int _llseek (unsigned int fd, unsigned long oh,
-+static int __llseek (unsigned int fd, unsigned long oh,
-                   unsigned long ol, long long *result,
-                   unsigned int origin) {
-       errno = ENOSYS;
-@@ -47,17 +41,8 @@
- #endif
--static long long my_llseek (unsigned int fd, long long offset,
--              unsigned int origin)
--{
--      long long result;
--      int retval;
--
--      retval = _llseek (fd, ((unsigned long long) offset) >> 32,
--                      ((unsigned long long) offset) & 0xffffffff,
--                      &result, origin);
--      return (retval == -1 ? (long long) retval : result);
--}
-+extern long long llseek(unsigned int fd, long long offset, unsigned int origin);
-+#define my_llseek llseek
- #endif /* __alpha__ */
-Index: util-linux-2.12r/fdisk/sfdisk.c
-===================================================================
---- util-linux-2.12r.orig/fdisk/sfdisk.c       2007-06-04 13:22:28.265558264 +0200
-+++ util-linux-2.12r/fdisk/sfdisk.c    2007-06-04 13:22:28.338547168 +0200
-@@ -176,12 +176,6 @@
- #define use_lseek
- #endif
--#ifndef use_lseek
--static __attribute__used
--_syscall5(int,  _llseek,  unsigned int,  fd, ulong, hi, ulong, lo,
--       loff_t *, res, unsigned int, wh);
--#endif
--
- static int
- sseek(char *dev, unsigned int fd, unsigned long s) {
-     loff_t in, out;
-Index: util-linux-2.12r/partx/partx.c
-===================================================================
---- util-linux-2.12r.orig/partx/partx.c        2007-06-04 13:22:28.272557200 +0200
-+++ util-linux-2.12r/partx/partx.c     2007-06-04 13:22:28.339547016 +0200
-@@ -339,9 +339,6 @@
- #ifdef NEED__llseek
- #include <linux/unistd.h>       /* _syscall */
--static
--_syscall5(int,  _llseek,  uint,  fd, ulong, hi, ulong, lo,
--        long long *, res, uint, wh);
- #endif
- static int
diff --git a/package/util-linux/patches/501-mconfig.patch b/package/util-linux/patches/501-mconfig.patch
deleted file mode 100644 (file)
index 867352d..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-Index: util-linux-2.12r/MCONFIG
-===================================================================
---- util-linux-2.12r.orig/MCONFIG      2007-06-04 13:22:28.239562216 +0200
-+++ util-linux-2.12r/MCONFIG   2007-06-04 13:22:28.549515096 +0200
-@@ -16,8 +16,8 @@
- # Select for ARCH one of intel, alpha, sparc, arm, m68k, mips
- # Select for CPU i386 if the binaries must be able to run on an intel 386
- # (by default i486 code is generated, see below)
--CPU=$(shell uname -m)
--ARCH=$(shell echo $(CPU) | sed 's/i.86/intel/;s/arm.*/arm/')
-+CPU=
-+ARCH=mips
- # If HAVE_PAM is set to "yes", then login, chfn, chsh, and newgrp
- # will use PAM for authentication. Additionally, passwd will not be
-@@ -64,12 +64,12 @@
- # If HAVE_WRITE is set to "yes", then write will not be built or
- # installed from the misc-utils subdirectory.
- # (There is a network aware write in netwrite from NetKit 0.16 or later.)
--HAVE_WRITE=no
-+HAVE_WRITE=yes
- # If HAVE_GETTY is set to "yes", then agetty will not be built or
- # installed from the login-utils subdirectory.  Note that agetty can
- # co-exist with other gettys, so this option should never be used.
--HAVE_GETTY=no
-+HAVE_GETTY=yes
- # If USE_TTY_GROUP is set to "yes", then wall and write will be installed
- # setgid to the "tty" group, and mesg will only set the group write bit.
-@@ -82,13 +82,13 @@
- # If HAVE_KILL is set to "yes", then kill will not be built or
- # installed from the misc-utils subdirectory.
- # (There is also a kill in the procps package.)
--HAVE_KILL=no
-+HAVE_KILL=yes
- # If ALLOW_VCS_USE is set to "yes", then login will chown /dev/vcsN
- # to the current user, allowing her to make a screendump and do other
- # nifty things on the console, but also allowing him to keep an open
- # file descriptor after logging out to trick the next user.
--ALLOW_VCS_USE=yes
-+ALLOW_VCS_USE=no
- # If DO_STAT_MAIL is set to "yes", then login will stat() the mailbox
- # and tell the user that she has new mail. This can hang the login if
-@@ -102,19 +102,19 @@
- # If HAVE_SLN is set to "yes", then sln won't be installed
- # (but the man page sln.8 will be installed anyway).
- # sln also comes with libc and glibc.
--HAVE_SLN=no
-+HAVE_SLN=yes
- # If HAVE_FDUTILS is set to "yes", then setfdprm won't be installed.
--HAVE_FDUTILS=no
-+HAVE_FDUTILS=yes
- # If SILENT_PG is set to "yes", then pg will not ring the bell
- # when an invalid key is pressed
--SILENT_PG=no
-+SILENT_PG=yes
- # If configure decides that Native Language Support (NLS) is available,
- # it sets MAY_ENABLE_NLS in defines.h. If you don't want NLS, set
- # DISABLE_NLS to "yes".
--DISABLE_NLS=no
-+DISABLE_NLS=yes
- # Different optimizations for different cpus.
- # Before gcc 2.8.0 only -m486
diff --git a/package/util-linux/patches/601-util-linux-2.12r-umount-no-special.patch b/package/util-linux/patches/601-util-linux-2.12r-umount-no-special.patch
deleted file mode 100644 (file)
index 114c18f..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: util-linux-2.12r/mount/umount.c
-===================================================================
---- util-linux-2.12r.orig/mount/umount.c       2007-06-04 13:22:28.218565408 +0200
-+++ util-linux-2.12r/mount/umount.c    2007-06-04 13:22:28.736486672 +0200
-@@ -31,7 +31,7 @@
- #include <arpa/inet.h>
- #endif
--#if defined(MNT_FORCE) && !defined(__sparc__) && !defined(__arm__)
-+#if defined(MNT_FORCE)
- /* Interesting ... it seems libc knows about MNT_FORCE and presumably
-    about umount2 as well -- need not do anything */
- #else /* MNT_FORCE */
diff --git a/package/util-linux/patches/801-cris_avr32_label.patch b/package/util-linux/patches/801-cris_avr32_label.patch
deleted file mode 100644 (file)
index d281949..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- util-linux-2.12r.orig/fdisk/fdiskbsdlabel.h        2007-06-12 21:32:25.000000000 +0200
-+++ util-linux-2.12r/fdisk/fdiskbsdlabel.h     2007-06-12 21:33:20.000000000 +0200
-@@ -43,7 +43,7 @@
- #define BSD_LINUX_BOOTDIR "/usr/ucb/mdec"
--#if defined (i386) || defined (__sparc__) || defined (__arm__) || defined (__mips__) || defined (__s390__) || defined (__sh__) || defined(__x86_64__)
-+#if defined (i386) || defined (__sparc__) || defined (__arm__) || defined (__mips__) || defined (__s390__) || defined (__sh__) || defined(__x86_64__) || defined (__cris__) || defined(__avr32__)
- #define BSD_LABELSECTOR   1
- #define BSD_LABELOFFSET   0
- #elif defined (__alpha__) || defined (__powerpc__) || defined (__ia64__) || defined (__hppa__)