change handling of the Build/Clean template
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Jun 2006 00:34:11 +0000 (00:34 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Jun 2006 00:34:11 +0000 (00:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3930 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/rules.mk

index d44cd98..77a6595 100644 (file)
@@ -257,10 +257,6 @@ define Build/Compile
   $(call Build/Compile/Default,)
 endef
 
-define Build/Clean
-       $(MAKE) clean
-endef
-
 ifneq ($(DUMP),)
   dumpinfo: FORCE
        @$(DUMPINFO)
@@ -282,5 +278,6 @@ else
   clean-targets:
   clean: FORCE
        @$(MAKE) clean-targets
+       $(call Build/Clean)
        rm -rf $(PKG_BUILD_DIR)
 endif