kernel: update linux 3.2 to 3.2.12
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 Mar 2012 18:23:31 +0000 (18:23 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 Mar 2012 18:23:31 +0000 (18:23 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31028 3c298f89-4303-0410-b956-a3cf2f4a3e73

17 files changed:
include/kernel-version.mk
target/linux/ar71xx/Makefile
target/linux/au1000/Makefile
target/linux/brcm47xx/Makefile
target/linux/cns21xx/Makefile
target/linux/ep93xx/Makefile
target/linux/generic/patches-3.2/440-block2mtd_init.patch
target/linux/generic/patches-3.2/643-bridge_remove_ipv6_dependency.patch
target/linux/generic/patches-3.2/644-bridge_optimize_netfilter_hooks.patch
target/linux/malta/Makefile
target/linux/mpc52xx/Makefile
target/linux/omap4/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ppc44x/patches/100-openwrt_flashmap.patch
target/linux/ramips/Makefile
target/linux/uml/Makefile

index 41f100a..f2e39c0 100644 (file)
@@ -35,8 +35,8 @@ endif
 ifeq ($(LINUX_VERSION),3.1.10)
   LINUX_KERNEL_MD5SUM:=3649bdaa50ffd9114cc16486ec54d83a
 endif
-ifeq ($(LINUX_VERSION),3.2.9)
-  LINUX_KERNEL_MD5SUM:=f6c2ede7c6df0f62c8fbf7932ccf63b6
+ifeq ($(LINUX_VERSION),3.2.12)
+  LINUX_KERNEL_MD5SUM:=e3dd3772f0cf14d444a3fb474bd624fe
 endif
 
 # disable the md5sum check for unknown kernel versions
index cd4a14d..30610f8 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 395afb8..0125d88 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index 6934893..dfa0cd7 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index 3c7a1d3..b519f39 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 4d8febc..6c5044b 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 53979b2..513fbca 100644 (file)
  {
 --- a/fs/partitions/check.c
 +++ b/fs/partitions/check.c
-@@ -664,6 +664,7 @@ rescan:
-       kfree(state);
+@@ -696,6 +696,7 @@ int invalidate_partitions(struct gendisk
        return 0;
  }
 +EXPORT_SYMBOL(rescan_partitions);
index 9203e01..6b79e54 100644 (file)
@@ -32,7 +32,7 @@
 +obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_stubs.o
 --- a/net/ipv6/addrconf.c
 +++ b/net/ipv6/addrconf.c
-@@ -1107,7 +1107,7 @@ out:
+@@ -1111,7 +1111,7 @@ out:
        return ret;
  }
  
@@ -41,7 +41,7 @@
                       const struct in6_addr *daddr, unsigned int prefs,
                       struct in6_addr *saddr)
  {
-@@ -1232,7 +1232,6 @@ try_nextdev:
+@@ -1236,7 +1236,6 @@ try_nextdev:
        in6_ifa_put(hiscore->ifa);
        return 0;
  }
@@ -49,7 +49,7 @@
  
  int ipv6_get_lladdr(struct net_device *dev, struct in6_addr *addr,
                    unsigned char banned_flags)
-@@ -4814,6 +4813,9 @@ int __init addrconf_init(void)
+@@ -4818,6 +4817,9 @@ int __init addrconf_init(void)
  
        ipv6_addr_label_rtnl_register();
  
@@ -59,7 +59,7 @@
        return 0;
  errout:
        rtnl_af_unregister(&inet6_ops);
-@@ -4832,6 +4834,9 @@ void addrconf_cleanup(void)
+@@ -4836,6 +4838,9 @@ void addrconf_cleanup(void)
        struct net_device *dev;
        int i;
  
index 06b05f8..9113985 100644 (file)
  
 --- a/net/bridge/br_multicast.c
 +++ b/net/bridge/br_multicast.c
-@@ -824,7 +824,7 @@ static void __br_multicast_send_query(st
+@@ -827,7 +827,7 @@ static void __br_multicast_send_query(st
        if (port) {
                __skb_push(skb, sizeof(struct ethhdr));
                skb->dev = port->dev;
index 119338c..47ade69 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 6d69e99..4c7cd5b 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 
index f806f9a..1f3f889 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=omap4
 BOARDNAME:=TI OMAP4
 FEATURES:=usb targz audio display
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
index 87d5d6b..cceee1d 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 629eab0..35addf2 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.2.11
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 225831a..471e686 100644 (file)
@@ -25,7 +25,7 @@
                                                label = "env";
 --- a/arch/powerpc/boot/dts/canyonlands.dts
 +++ b/arch/powerpc/boot/dts/canyonlands.dts
-@@ -217,24 +217,12 @@
+@@ -222,24 +222,12 @@
                                        #address-cells = <1>;
                                        #size-cells = <1>;
                                        partition@0 {
index 926d384..0bd0f7c 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 14a11db..4f4ef7f 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.9
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk