fix inclusion of kernel modules selected for install in images (closes: #598).
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jun 2006 21:37:07 +0000 (21:37 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jun 2006 21:37:07 +0000 (21:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4081 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index c110f68..b40f65f 100644 (file)
@@ -47,10 +47,10 @@ PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)_
 I_$(1) := $(KMOD_BUILD_DIR)/ipkg/$(2)
 
 ifeq ($$(KDEPEND_$(1)),m)
-ifneq ($(CONFIG_PACKAGE_KMOD_$(1)),)
+ifneq ($$(CONFIG_PACKAGE_KMOD_$(1)),)
 TARGETS += $$(PKG_$(1))
 endif
-ifeq ($(CONFIG_PACKAGE_KMOD_$(1)),y)
+ifeq ($$(CONFIG_PACKAGE_KMOD_$(1)),y)
 INSTALL_TARGETS += $$(PKG_$(1))
 endif
 endif