add clean targets, more FORCE stuff
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Jun 2006 00:19:52 +0000 (00:19 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Jun 2006 00:19:52 +0000 (00:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3882 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile

index 40b4efc..84508b1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -61,36 +61,45 @@ scripts/config/mconf: .config.in
 scripts/config/conf: .config.in
        $(MAKE) -C scripts/config conf
 
-config: scripts/config/conf
+config: scripts/config/conf FORCE
        $< Config.in
 
-defdconfig: scripts/config/conf
+defdconfig: scripts/config/conf FORCE
        $< -d Config.in
 
-oldconfig: scripts/config/conf
+oldconfig: scripts/config/conf FORCE
        $< -o Config.in
 
-menuconfig: scripts/config/mconf
+menuconfig: scripts/config/mconf FORCE
        $< Config.in
 
-config-clean:
+config-clean: FORCE
        $(MAKE) -C scripts/config clean
 
-package/%: .pkginfo
+package/%: .pkginfo FORCE
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
-target/%: .pkginfo
+target/%: .pkginfo FORCE
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
-toolchain/%:
+toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-world:
+world: FORCE
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile
        $(MAKE) package/install
        $(MAKE) target/install
 
+clean: FORCE
+       rm -rf build_* bin
+
+dirclean: clean FORCE
+       rm -rf staging_dir_* toolchain_build_*
+
+distclean: dirclean FORCE
+       rm -rf .* dl
+
 .PHONY: FORCE
 FORCE: